summaryrefslogtreecommitdiffstats
path: root/main/nautilus/gmodule-underlinking.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/nautilus/gmodule-underlinking.patch')
-rw-r--r--main/nautilus/gmodule-underlinking.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/nautilus/gmodule-underlinking.patch b/main/nautilus/gmodule-underlinking.patch
new file mode 100644
index 000000000..efb690c17
--- /dev/null
+++ b/main/nautilus/gmodule-underlinking.patch
@@ -0,0 +1,22 @@
+--- ./src/Makefile.in.orig
++++ ./src/Makefile.in
+@@ -469,7 +469,7 @@
+ LDADD = \
+ $(top_builddir)/src/file-manager/libnautilus-file-manager.la \
+ $(top_builddir)/libnautilus-private/libnautilus-private.la \
+- $(CORE_LIBS) \
++ $(CORE_LIBS) -lgmodule-2.0 \
+ $(EXIF_LIBS) \
+ $(EXEMPI_LIBS) \
+ $(POPT_LIBS) \
+--- ./test/Makefile.in.orig
++++ ./test/Makefile.in
+@@ -383,7 +383,7 @@
+
+ LDADD = \
+ $(top_builddir)/libnautilus-private/libnautilus-private.la \
+- $(CORE_LIBS) \
++ $(CORE_LIBS) -lgmodule-2.0 \
+ $(NULL)
+
+ test_nautilus_copy_SOURCES = test-copy.c test.c