summaryrefslogtreecommitdiffstats
path: root/main/net-snmp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/net-snmp/APKBUILD')
-rw-r--r--main/net-snmp/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/net-snmp/APKBUILD b/main/net-snmp/APKBUILD
index dce92cda1..75e8bd461 100644
--- a/main/net-snmp/APKBUILD
+++ b/main/net-snmp/APKBUILD
@@ -50,7 +50,10 @@ build() {
#build fails on: libnetsnmpmibs.so: undefined reference to `pthread_create'
LDFLAGS="$LDFLAGS -lpthread"
- ./configure --prefix=/usr \
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
@@ -66,7 +69,8 @@ build() {
--enable-shared \
--enable-as-needed \
--with-perl-modules="INSTALLDIRS=vendor" \
- --disable-embedded-perl
+ --disable-embedded-perl \
+ || return 1
# embedded-perl seems to create TEXTREL's
# work around parallell build issue