summaryrefslogtreecommitdiffstats
path: root/main/php/php-install-pear-xml.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/php/php-install-pear-xml.patch')
-rw-r--r--main/php/php-install-pear-xml.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/main/php/php-install-pear-xml.patch b/main/php/php-install-pear-xml.patch
new file mode 100644
index 000000000..f7a6fff58
--- /dev/null
+++ b/main/php/php-install-pear-xml.patch
@@ -0,0 +1,15 @@
+--- ./pear/Makefile.frag.orig
++++ ./pear/Makefile.frag
+@@ -2,8 +2,11 @@
+
+ peardir=$(PEAR_INSTALLDIR)
+
++# help the built php to find xml extension so we can install pear
++PEAR_INSTALL_XML_FLAGS = -d extension_dir="$(top_builddir)/modules" -d extension=xml.so
++
+ # Skip all php.ini files altogether
+-PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0 -dopen_basedir= -derror_reporting=1803 -dmemory_limit=-1 -ddetect_unicode=0
++PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0 -dopen_basedir= -derror_reporting=1803 -dmemory_limit=-1 -ddetect_unicode=0 $(PEAR_INSTALL_XML_FLAGS)
+
+ WGET = `which wget 2>/dev/null`
+ FETCH = `which fetch 2>/dev/null`