summaryrefslogtreecommitdiffstats
path: root/main/snmptt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/snmptt/APKBUILD')
-rw-r--r--main/snmptt/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/main/snmptt/APKBUILD b/main/snmptt/APKBUILD
new file mode 100644
index 000000000..041ac9a17
--- /dev/null
+++ b/main/snmptt/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Jeff Bilyk <jbilyk at gmail>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=snmptt
+pkgver=1.3
+pkgrel=0
+pkgdesc="Translates traps received from snmptrapd into easy to understand messages"
+url="http://www.snmptt.org"
+license="GPL"
+depends=perl
+makedepends=
+install=
+source="http://downloads.sourceforge.net/$pkgname/${pkgname}_$pkgver.tgz"
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$srcdir"/snmptt_${pkgver}
+ mkdir -p "$pkgdir"/var/log/snmptt
+ install -D -m755 snmptt "$pkgdir"/usr/bin/snmptt
+ install -D -m755 snmptthandler "$pkgdir"/usr/bin/snmptthandler
+ install -D -m755 snmpttconvert "$pkgdir"/usr/bin/snmpttconvert
+ install -D -m755 snmpttconvertmib "$pkgdir"/usr/bin/snmpttconvertmib
+ install -D -m644 snmptt.ini "$pkgdir"/etc/snmptt.ini
+}
+
+md5sums="ee8d8206d3e0d860fee126e09d8eb207 snmptt_1.3.tgz"