summaryrefslogtreecommitdiffstats
path: root/main/subversion/subversion-perl-deplibs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/subversion/subversion-perl-deplibs.patch')
-rw-r--r--main/subversion/subversion-perl-deplibs.patch38
1 files changed, 21 insertions, 17 deletions
diff --git a/main/subversion/subversion-perl-deplibs.patch b/main/subversion/subversion-perl-deplibs.patch
index e9757a286..13840a68e 100644
--- a/main/subversion/subversion-perl-deplibs.patch
+++ b/main/subversion/subversion-perl-deplibs.patch
@@ -1,21 +1,9 @@
---- subversion-1.7.2/subversion/bindings/swig/perl/native/Makefile.PL.in.orig
-+++ subversion-1.7.2/subversion/bindings/swig/perl/native/Makefile.PL.in
-@@ -49,11 +49,7 @@
- my $cflags = '@CFLAGS@';
- my $apr_cflags = '@SVN_APR_INCLUDES@';
- my $apu_cflags = '@SVN_APRUTIL_INCLUDES@';
--
--# According to the log of r7937, the flags guarded by the conditional break
--# the build on FreeBSD if not conditionalized.
--my $apr_ldflags = '@SVN_APR_LIBS@'
-- if $^O eq 'darwin' or $^O eq 'cygwin';
-+my $apr_ldflags = '@SVN_APR_LIBS@';
-
- chomp $apr_shlib_path_var;
+diff --git a/configure.ac b/configure.ac
+index 3481299..e0efde9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -327,7 +327,7 @@ AC_SUBST(LT_NO_UNDEFINED)
---- subversion-1.7.2/configure.ac.orig
-+++ subversion-1.7.2/configure.ac
-@@ -328,6 +328,6 @@
AC_MSG_CHECKING([whether to avoid circular linkage at all costs])
case $host in
- *-*-cygwin*)
@@ -23,3 +11,19 @@
AC_MSG_RESULT([yes])
AC_DEFINE([SVN_AVOID_CIRCULAR_LINKAGE_AT_ALL_COSTS_HACK], 1,
[Define if circular linkage is not possible on this platform.])
+diff --git a/subversion/bindings/swig/perl/native/Makefile.PL.in b/subversion/bindings/swig/perl/native/Makefile.PL.in
+index 27d507c..d496273 100644
+--- a/subversion/bindings/swig/perl/native/Makefile.PL.in
++++ b/subversion/bindings/swig/perl/native/Makefile.PL.in
+@@ -55,10 +55,7 @@ my $apu_cflags = '@SVN_APRUTIL_INCLUDES@';
+ # SWIG is using C++ style comments in an extern "C" code.
+ $cflags =~ s/-ansi\s+//g;
+
+-# According to the log of r7937, the flags guarded by the conditional break
+-# the build on FreeBSD if not conditionalized.
+-my $apr_ldflags = '@SVN_APR_LIBS@'
+- if $^O eq 'darwin' or $^O eq 'cygwin';
++my $apr_ldflags = '@SVN_APR_LIBS@';
+
+ chomp $apr_shlib_path_var;
+