summaryrefslogtreecommitdiffstats
path: root/main/tzdata/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/tzdata/Makefile.patch')
-rw-r--r--main/tzdata/Makefile.patch29
1 files changed, 17 insertions, 12 deletions
diff --git a/main/tzdata/Makefile.patch b/main/tzdata/Makefile.patch
index 9caefcbfb..7e6e38d6a 100644
--- a/main/tzdata/Makefile.patch
+++ b/main/tzdata/Makefile.patch
@@ -1,6 +1,8 @@
---- ./Makefile.orig 2013-02-27 17:20:35.000000000 +0000
-+++ ./Makefile 2013-03-13 15:03:39.518555524 +0000
-@@ -45,17 +45,17 @@
+diff --git a/Makefile b/Makefile
+index 3659378..3d9c9d1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -45,20 +45,20 @@ POSIXRULES= America/New_York
# Everything gets put in subdirectories of. . .
@@ -14,14 +16,17 @@
-TZDIR= $(TOPDIR)/etc/zoneinfo
+TZDIR= $(TOPDIR)/share/zoneinfo
+ # Types to try, as an alternative to time_t. int64_t should be first.
+ TIME_T_ALTERNATIVES= int64_t int32_t uint32_t uint64_t
+
# The "tzselect", "zic", and "zdump" commands get installed in. . .
-ETCDIR= $(TOPDIR)/etc
-+SBINDIR= $(TOPDIR)/sbin
++SBINDIR= $(TOPDIR)/sbin
# If you "make INSTALL", the "date" command gets installed in. . .
-@@ -63,7 +63,7 @@
+@@ -66,7 +66,7 @@ BINDIR= $(TOPDIR)/bin
# Manual pages go in subdirectories of. . .
@@ -30,7 +35,7 @@
# Library functions are put in an archive in LIBDIR.
-@@ -94,7 +94,7 @@
+@@ -97,7 +97,7 @@ YEARISTYPE= ./yearistype
# Non-default libraries needed to link.
# Add -lintl if you want to use `gettext' on Solaris.
@@ -39,7 +44,7 @@
# Add the following to the end of the "CFLAGS=" line as needed.
# -DHAVE_ADJTIME=0 if `adjtime' does not exist (SVR0?)
-@@ -228,7 +228,7 @@
+@@ -231,7 +231,7 @@ GCC_DEBUG_FLAGS = -Dlint -g3 -O3 -fno-common -fstrict-aliasing \
# before the first Monday in January when a "%V" format is used and January 1
# falls on a Friday, Saturday, or Sunday.
@@ -48,7 +53,7 @@
# Linker flags. Default to $(LFLAGS) for backwards compatibility
# to tzcode2012h and earlier.
-@@ -289,8 +289,10 @@
+@@ -292,8 +292,10 @@ GZIPFLAGS= -9n
###############################################################################
@@ -61,7 +66,7 @@
TZCSRCS= zic.c localtime.c asctime.c scheck.c ialloc.c
TZCOBJS= zic.o localtime.o asctime.o scheck.o ialloc.o
-@@ -331,14 +333,16 @@
+@@ -334,14 +336,16 @@ all: tzselect zic zdump $(LIBOBJS)
ALL: all date
@@ -82,7 +87,7 @@
$(MANDIR)/man3 $(MANDIR)/man5 $(MANDIR)/man8
-rm -f $(MANDIR)/man3/newctime.3 \
$(MANDIR)/man3/newtzset.3 \
-@@ -347,13 +351,11 @@
+@@ -350,13 +354,11 @@ install: all $(DATA) $(REDO) $(TZLIB) $(MANS) $(TABDATA)
$(MANDIR)/man8/zdump.8 \
$(MANDIR)/man8/zic.8
cp newctime.3 newtzset.3 $(MANDIR)/man3/.
@@ -98,7 +103,7 @@
-rm -f $(MANDIR)/man1/date.1
cp date.1 $(MANDIR)/man1/.
-@@ -388,9 +390,9 @@
+@@ -391,9 +393,9 @@ right_only: zic leapseconds $(TDATA)
# You must replace all of $(TZDIR) to switch from not using leap seconds
# to using them, or vice versa.
other_two: zic leapseconds $(TDATA)
@@ -110,7 +115,7 @@
posix_right: posix_only other_two
-@@ -418,7 +420,7 @@
+@@ -421,7 +423,7 @@ tzselect: tzselect.ksh
<$? >$@
chmod +x $@