summaryrefslogtreecommitdiffstats
path: root/main/wireless-tools/wireless-tools-29-asneeded.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/wireless-tools/wireless-tools-29-asneeded.patch')
-rw-r--r--main/wireless-tools/wireless-tools-29-asneeded.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/main/wireless-tools/wireless-tools-29-asneeded.patch b/main/wireless-tools/wireless-tools-29-asneeded.patch
new file mode 100644
index 000000000..04f2d869b
--- /dev/null
+++ b/main/wireless-tools/wireless-tools-29-asneeded.patch
@@ -0,0 +1,13 @@
+Index: wireless_tools.29/Makefile
+===================================================================
+--- wireless_tools.29.orig/Makefile
++++ wireless_tools.29/Makefile
+@@ -145,7 +145,7 @@ wireless.h:
+
+ # Compilation of the dynamic library
+ $(DYNAMIC): $(OBJS:.o=.so)
+- $(CC) -shared -o $@ -Wl,-soname,$@ $(STRIPFLAGS) $(LIBS) -lc $^
++ $(CC) $(LDFLAGS) -shared -o $@ -Wl,-soname,$@ $(STRIPFLAGS) $^ $(LIBS) -lc
+
+ # Compilation of the static library
+ $(STATIC): $(OBJS:.o=.so)