summaryrefslogtreecommitdiffstats
path: root/main/xulrunner/fix-toolkit.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/xulrunner/fix-toolkit.patch')
-rw-r--r--main/xulrunner/fix-toolkit.patch52
1 files changed, 30 insertions, 22 deletions
diff --git a/main/xulrunner/fix-toolkit.patch b/main/xulrunner/fix-toolkit.patch
index a368205b1..647aa9f70 100644
--- a/main/xulrunner/fix-toolkit.patch
+++ b/main/xulrunner/fix-toolkit.patch
@@ -1,5 +1,6 @@
---- mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc
-+++ mozilla-release/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc
+diff -ru mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc mozilla-release/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc
+--- mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc 2014-03-15 05:19:36.000000000 +0000
++++ mozilla-release/toolkit/crashreporter/google-breakpad/src/common/linux/dump_symbols.cc 2014-04-17 10:24:33.793431933 +0000
@@ -45,6 +45,7 @@
#include <sys/mman.h>
#include <sys/stat.h>
@@ -8,8 +9,9 @@
#include <iostream>
#include <set>
---- mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/common/stabs_reader.cc
-+++ mozilla-release/toolkit/crashreporter/google-breakpad/src/common/stabs_reader.cc
+diff -ru mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/common/stabs_reader.cc mozilla-release/toolkit/crashreporter/google-breakpad/src/common/stabs_reader.cc
+--- mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/common/stabs_reader.cc 2014-03-15 05:19:36.000000000 +0000
++++ mozilla-release/toolkit/crashreporter/google-breakpad/src/common/stabs_reader.cc 2014-04-17 10:24:33.793431933 +0000
@@ -41,6 +41,10 @@
#include "common/using_std_string.h"
@@ -21,8 +23,9 @@
using std::vector;
namespace google_breakpad {
---- mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/common/stabs_reader.h
-+++ mozilla-release/toolkit/crashreporter/google-breakpad/src/common/stabs_reader.h
+diff -ru mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/common/stabs_reader.h mozilla-release/toolkit/crashreporter/google-breakpad/src/common/stabs_reader.h
+--- mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/common/stabs_reader.h 2014-03-15 05:19:36.000000000 +0000
++++ mozilla-release/toolkit/crashreporter/google-breakpad/src/common/stabs_reader.h 2014-04-17 10:24:33.793431933 +0000
@@ -53,9 +53,10 @@
#include <config.h>
#endif
@@ -35,8 +38,9 @@
#ifdef HAVE_MACH_O_NLIST_H
#include <mach-o/nlist.h>
#endif
---- mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h
-+++ mozilla-release/toolkit/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h
+diff -ru mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h mozilla-release/toolkit/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h
+--- mozilla-release/toolkit.orig/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h 2014-03-15 05:19:37.000000000 +0000
++++ mozilla-release/toolkit/crashreporter/google-breakpad/src/third_party/lss/linux_syscall_support.h 2014-04-17 10:24:33.793431933 +0000
@@ -2813,7 +2813,7 @@
LSS_INLINE _syscall6(void*, mmap, void*, s,
size_t, l, int, p,
@@ -46,19 +50,21 @@
LSS_INLINE _syscall4(int, newfstatat, int, d,
const char *, p,
---- mozilla-release/toolkit.orig/library/Makefile.in
-+++ mozilla-release/toolkit/library/Makefile.in
-@@ -423,7 +423,7 @@
+diff -ru mozilla-release/toolkit.orig/library/Makefile.in mozilla-release/toolkit/library/Makefile.in
+--- mozilla-release/toolkit.orig/library/Makefile.in 2014-03-15 05:19:37.000000000 +0000
++++ mozilla-release/toolkit/library/Makefile.in 2014-04-17 10:24:56.780511957 +0000
+@@ -199,7 +199,7 @@
+ endif
- ifdef MOZ_CUBEB
-ifdef MOZ_ALSA
+ifdef MOZ_ALSA_LIBS
EXTRA_DSO_LDOPTS += $(MOZ_ALSA_LIBS)
endif
- ifdef MOZ_PULSEAUDIO
---- mozilla-release/toolkit.orig/mozapps/update/common/updatedefines.h
-+++ mozilla-release/toolkit/mozapps/update/common/updatedefines.h
+
+diff -ru mozilla-release/toolkit.orig/mozapps/update/common/updatedefines.h mozilla-release/toolkit/mozapps/update/common/updatedefines.h
+--- mozilla-release/toolkit.orig/mozapps/update/common/updatedefines.h 2014-03-15 05:19:37.000000000 +0000
++++ mozilla-release/toolkit/mozapps/update/common/updatedefines.h 2014-04-17 10:24:33.793431933 +0000
@@ -105,7 +105,7 @@
#ifdef SOLARIS
@@ -68,9 +74,10 @@
# include <fts.h>
#endif
# include <dirent.h>
---- mozilla-release/toolkit.orig/mozapps/update/updater/updater.cpp
-+++ mozilla-release/toolkit/mozapps/update/updater/updater.cpp
-@@ -3422,6 +3422,7 @@
+diff -ru mozilla-release/toolkit.orig/mozapps/update/updater/updater.cpp mozilla-release/toolkit/mozapps/update/updater/updater.cpp
+--- mozilla-release/toolkit.orig/mozapps/update/updater/updater.cpp 2014-03-15 05:19:37.000000000 +0000
++++ mozilla-release/toolkit/mozapps/update/updater/updater.cpp 2014-04-17 10:24:33.796765327 +0000
+@@ -3432,6 +3432,7 @@
int add_dir_entries(const NS_tchar *dirpath, ActionList *list)
{
int rv = OK;
@@ -78,7 +85,7 @@
FTS *ftsdir;
FTSENT *ftsdirEntry;
NS_tchar searchpath[MAXPATHLEN];
-@@ -3524,6 +3525,7 @@
+@@ -3534,6 +3535,7 @@
}
fts_close(ftsdir);
@@ -86,8 +93,9 @@
return rv;
}
---- mozilla-release.orig/toolkit/xre/nsSigHandlers.cpp Fri Aug 02 14:36:52 2013 +0000
-+++ mozilla-release/toolkit/xre/nsSigHandlers.cpp Fri Aug 02 14:42:20 2013 +0000
+diff -ru mozilla-release/toolkit.orig/xre/nsSigHandlers.cpp mozilla-release/toolkit/xre/nsSigHandlers.cpp
+--- mozilla-release/toolkit.orig/xre/nsSigHandlers.cpp 2014-03-15 05:19:38.000000000 +0000
++++ mozilla-release/toolkit/xre/nsSigHandlers.cpp 2014-04-17 10:24:33.796765327 +0000
@@ -15,6 +15,7 @@
#include <signal.h>
#include <stdio.h>
@@ -152,4 +160,4 @@
+ u_int32_t *mxcsr = &uc->uc_mcontext.fpregs.fp_reg_set.fpchip_state.mxcsr;
*mxcsr |= SSE_EXCEPTION_MASK; /* disable all SSE exceptions */
*mxcsr &= ~SSE_STATUS_FLAGS; /* clear all pending SSE exceptions */
-#endif
+ #endif