summaryrefslogtreecommitdiffstats
path: root/main/zabbix/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/zabbix/APKBUILD')
-rw-r--r--main/zabbix/APKBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/main/zabbix/APKBUILD b/main/zabbix/APKBUILD
index 755891156..d37c6750a 100644
--- a/main/zabbix/APKBUILD
+++ b/main/zabbix/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=zabbix
pkgver=2.2.6
-pkgrel=0
+pkgrel=1
pkgdesc="Enterprise-class open source distributed monitoring"
url="http://www.zabbix.com"
arch="all"
@@ -40,15 +40,13 @@ prepare() {
for i in $source; do
case $i in
*uclibc*.patch)
- ret=`echo $CHOST | grep -q uclibc`
- if [ "$ret" == "0" ]; then
+ if [ "$CLIBC" == "uclibc" ]; then
msg "Applying $i"
patch -p1 -i "$srcdir"/$i || return 1
fi
;;
*eglibc*.patch)
- ret=`echo $CHOST | grep -q eglibc`
- if [ "$ret" = "0" ]; then
+ if [ "$CLIBC" == "eglibc" ]; then
msg "Applying $i"
patch -p1 -i "$srcdir"/$i || return 1
fi