summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/clamav/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/clamav/APKBUILD b/main/clamav/APKBUILD
index 8e84012e6..529a9b73a 100644
--- a/main/clamav/APKBUILD
+++ b/main/clamav/APKBUILD
@@ -59,7 +59,7 @@ package() {
-e "s:^\#\(NotifyClamd\).*:\1 /etc/clamav/clamd.conf:" \
-e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
-e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
- "$pkgdir"/etc/clamav/freshclam.conf
+ "$pkgdir"/etc/clamav/freshclam.conf.sample
# set proper defaults
sed -i -e "s:^\(Example\):\# \1:" \
@@ -69,7 +69,7 @@ package() {
-e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
-e "s:^\#\(LogTime\).*:\1 yes:" \
-e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
- "$pkgdir"/etc/clamav/clamd.conf
+ "$pkgdir"/etc/clamav/clamd.conf.sample
}
lib() {
@@ -100,7 +100,7 @@ freshclam() {
"$subpkgdir"/etc/clamav
mv "$pkgdir"/usr/bin/freshclam "$subpkgdir"/usr/bin || return 1
- mv "$pkgdir"/etc/clamav/freshclam.conf \
+ mv "$pkgdir"/etc/clamav/freshclam.conf.sample \
"$subpkgdir"/etc/clamav/ || return 1
install -d -m755 -o clamav -g clamav \
"$subpkgdir"/var/run/clamav \
@@ -162,7 +162,7 @@ daemon() {
"$subpkgdir"/usr/bin/ || return 1
mv "$pkgdir"/usr/bin/clamdscan \
"$subpkgdir"/usr/bin/ || return 1
- mv "$pkgdir"/etc/clamav/clamd.conf \
+ mv "$pkgdir"/etc/clamav/clamd.conf.sample \
"$subpkgdir"/etc/clamav/ || return 1
install -m755 -D "$srcdir"/clamd.initd \
"$subpkgdir"/etc/init.d/clamd || return 1