summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/x264/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/x264/APKBUILD b/main/x264/APKBUILD
index 6f3435ff4..e766e0ac3 100644
--- a/main/x264/APKBUILD
+++ b/main/x264/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=x264
pkgver=20130409
-pkgrel=1
+pkgrel=2
pkgdesc="free library for encoding H264/AVC video streams"
url="http://www.videolan.org/developers/x264.html"
arch="all"
@@ -12,7 +12,7 @@ subpackages="$pkgname-dev"
source="ftp://ftp.videolan.org/pub/x264/snapshots/x264-snapshot-$pkgver-2245-stable.tar.bz2"
_builddir="$srcdir/$pkgname-snapshot-$pkgver-2245-stable"
-build() {
+build() {
cd "$_builddir"
local _asmopts=
@@ -30,6 +30,7 @@ build() {
--enable-shared \
$_asmopts \
--enable-pic \
+ --extra-cflags=-fno-aggressive-loop-optimizations \
|| return 1
make || return 1
}