summaryrefslogtreecommitdiffstats
path: root/testing/bacula/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/bacula/APKBUILD')
-rw-r--r--testing/bacula/APKBUILD96
1 files changed, 0 insertions, 96 deletions
diff --git a/testing/bacula/APKBUILD b/testing/bacula/APKBUILD
deleted file mode 100644
index ff4161ea1..000000000
--- a/testing/bacula/APKBUILD
+++ /dev/null
@@ -1,96 +0,0 @@
-# Contributor: Leonardo Arena <rnalrd@gmail.com>
-# Maintainer: Leonardo Arena <rnalrd@gmail.com>
-pkgname="bacula"
-pkgver=5.0.1
-pkgrel=3
-pkgdesc="Enterprise ready, network based backup program"
-url="http://www.bacula.org"
-license="GPL2"
-depends="postgresql"
-makedepends="postgresql-dev openssl-dev ncurses-dev autoconf"
-install="$pkgname.pre-install $pkgname.post-install"
-subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz
-bacula-dir-init
-bacula-dir-conf
-bacula-sd-init
-bacula-sd-conf
-bacula-fd-init
-bacula-fd-conf
-configure.in.patch
-os.m4.patch"
-
-prepare () {
- cd "$srcdir/$pkgname-$pkgver"
- patch -p1 < ../../configure.in.patch
- patch -p1 < ../../os.m4.patch
-}
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- export LDFLAGS=
- # Need to run configure at least once
- # in order to do not go into an infinite loop
- ./configure
- make configure
- make distclean
-
- ./configure --prefix=/usr \
- --sysconfdir=/etc/bacula \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --docdir=/usr/share/doc \
- --infodir=/usr/share/info \
- --with-pid-dir=/var/run \
- --with-subsys-dir=/var/lock/subsys \
- --with-logdir=/var/log \
- --enable-largefile \
- --enable-smartalloc \
- --disable-nls \
- --with-openssl=/usr/include/openssl \
- --with-postgresql \
- --with-scriptdir=/etc/bacula/scripts \
- --with-working-dir=/var/bacula \
- --with-dir-user=bacula \
- --with-dir-group=bacula \
- --with-sd-user=bacula \
- --with-sd-group=bacula \
- --with-fd-user=root \
- --with-fd-group=root \
- --with-dir-password=PuemReTsKKObLe3TTaU73a3dPWwISW \
- --with-fd-password=Mbh1ujsgZ2ogRFVjPWD9TAVMFP6o8E \
- --with-sd-password=icpaksuq0gpDStLT8Uqgk1HIozFnx1 \
- --with-db-password=BQrlfPPfdXdMHlJID0HrGHZde2Lqd9
-
- make || return 1
-}
-
-package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
-
- for DAEMON in dir sd fd
- do
- install -Dm755 "$srcdir"/bacula-${DAEMON}-init \
- "$pkgdir"/etc/init.d/bacula-${DAEMON}
- install -Dm644 "$srcdir"/bacula-${DAEMON}-conf \
- "$pkgdir"/etc/conf.d/bacula-${DAEMON}
- done
- install -Dm644 examples/sample-query.sql "$pkgdir"/etc/bacula/scripts/query.sql
- mkdir -p "$pkgdir"/var/run/bacula
- # Fix correct log dir
- sed -i -e 's%/var/bacula/log%/var/log/bacula%' "$pkgdir"/etc/bacula/bacula-dir.conf
- # Install logrotate script
- install -Dm644 scripts/logrotate $pkgdir/etc/logrotate.d/bacula
- sed -i -e 's%/var/bacula/log%/var/log/bacula%' "$pkgdir"/etc/logrotate.d/bacula
-}
-
-md5sums="beb9f8da196b3c9ffb0356f087dbdb99 bacula-5.0.1.tar.gz
-b1b328013634c98119663730e3e2da7e bacula-dir-init
-20f28a16f34e3f20ed18ed81b010e765 bacula-dir-conf
-5ae1fba6860a320394d65744e5640bdb bacula-sd-init
-afe2f9a4d79d7d96eb9372d003d10f86 bacula-sd-conf
-6ae93e570f95fa845fa534c2d2efaac0 bacula-fd-init
-4500ce2d62bf9df33c07f70dc40f7b85 bacula-fd-conf
-ebc9c2bbc9be95c920723a3f142d8e19 configure.in.patch
-cf7a2a4e972697f54364654c4e282b8b os.m4.patch"