summaryrefslogtreecommitdiffstats
path: root/testing/chmlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/chmlib/APKBUILD')
-rw-r--r--testing/chmlib/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/chmlib/APKBUILD b/testing/chmlib/APKBUILD
new file mode 100644
index 000000000..a3b5013ed
--- /dev/null
+++ b/testing/chmlib/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=chmlib
+pkgver=0.40
+pkgrel=0
+pkgdesc="Library for dealing with Microsoft ITSS/CHM format files"
+url="http://morte.jedrea.com/~jedwin/projects/chmlib/"
+arch="all"
+license="LGPL"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://morte.jedrea.com/~jedwin/projects/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="7ea49ed8c335215c1edc6fae83e6b912 chmlib-0.40.tar.bz2"