summaryrefslogtreecommitdiffstats
path: root/testing/kbuild/strlcpy.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kbuild/strlcpy.patch')
-rw-r--r--testing/kbuild/strlcpy.patch15
1 files changed, 1 insertions, 14 deletions
diff --git a/testing/kbuild/strlcpy.patch b/testing/kbuild/strlcpy.patch
index 42b25bdad..d0b3a0471 100644
--- a/testing/kbuild/strlcpy.patch
+++ b/testing/kbuild/strlcpy.patch
@@ -7,20 +7,7 @@ index 44b76ab..85fec01 100644
#include "kbuild_protection.h"
-#if defined(_MSC_VER) || defined(__gnu_linux__) || defined(__linux__)
-+#if defined(_MSC_VER) || defined(__gnu_linux__) || defined(__linux__) && !defined(__UCLIBC__)
++#if defined(_MSC_VER) || defined(__gnu_linux__) && !defined(__UCLIBC__)
extern char *strlcpy(char *, const char *, size_t);
#endif
-diff --git a/src/kmk/Makefile.kmk b/src/kmk/Makefile.kmk
-index 12b9697..db1deb2 100644
---- a/src/kmk/Makefile.kmk
-+++ b/src/kmk/Makefile.kmk
-@@ -101,7 +101,7 @@ kmkmissing_SOURCES.freebsd = \
- glob/fnmatch.c
-
- kmkmissing_SOURCES.linux += \
-- kmkbuiltin/strlcpy.c
-+ getloadavg.c
-
- kmkmissing_SOURCES.solaris = \
- kmkbuiltin/strlcpy.c \