summaryrefslogtreecommitdiffstats
path: root/testing/libestr/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libestr/APKBUILD')
-rw-r--r--testing/libestr/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/libestr/APKBUILD b/testing/libestr/APKBUILD
new file mode 100644
index 000000000..3ce89068d
--- /dev/null
+++ b/testing/libestr/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Uros
+# Maintainer: Cameron Banta <cbanta@gmail.com>
+pkgname=libestr
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="essentials for string handling (and a bit more)"
+url="http://libestr.adiscon.com"
+arch="all"
+license="LGPL2.1"
+subpackages="$pkgname-dev"
+source="http://libestr.adiscon.com/files/download/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ ./configure --prefix=/usr || return 1
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -rf "$pkgdir"/usr/lib/libestr.la
+}
+
+md5sums="30ec4054155dc7d7e9b06418181c4f12 libestr-0.1.2.tar.gz"