summaryrefslogtreecommitdiffstats
path: root/testing/madwimax/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/madwimax/APKBUILD')
-rw-r--r--testing/madwimax/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/madwimax/APKBUILD b/testing/madwimax/APKBUILD
new file mode 100644
index 000000000..251ff801a
--- /dev/null
+++ b/testing/madwimax/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Sergey
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=madwimax
+pkgver=0.1.1
+pkgrel=0
+pkgdesc="WiMAX driver for the Samsung SWC-U200 and similar USB modems"
+url="http://code.google.com/p/madwimax/"
+license="GPL-2"
+depends=
+makedepends="pkgconfig libusb-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://madwimax.googlecode.com/files/madwimax-0.1.1.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --without-man-pages \
+ || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+#2009-10-07,SP: you can start it simply by /usr/sbin/madwimax -d
+#, so no init.d script so far...
+
+}
+
+md5sums="4ebd2d74e887e6f9d6f23067a4ad8272 madwimax-0.1.1.tar.gz"