summaryrefslogtreecommitdiffstats
path: root/testing/mailx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mailx/APKBUILD')
-rw-r--r--testing/mailx/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/mailx/APKBUILD b/testing/mailx/APKBUILD
new file mode 100644
index 000000000..bf3ea7319
--- /dev/null
+++ b/testing/mailx/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=mailx
+pkgver=8.1.1
+pkgrel=0
+pkgdesc="A commandline utility for sending email"
+url="http://www.opengroup.org/onlinepubs/007908799/xcu/mailx.html"
+arch="all"
+license="BSD"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="ftp://ftp.archlinux.org/other/mailx/$pkgname-$pkgver-fixed.tar.gz
+ mailx-8.1.1.patch
+ mailx-gcc4.patch"
+
+_builddir="$srcdir/$pkgname-$pkgver-fixed"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i 's#/man/#/share/man/#' Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="63cad526ac64b57bcba2c0daaa1f3048 mailx-8.1.1-fixed.tar.gz
+d66b9f419c5d215271ed434f5d780843 mailx-8.1.1.patch
+8716c7c7b3f5d348443230e2fe543bf6 mailx-gcc4.patch"