summaryrefslogtreecommitdiffstats
path: root/testing/prayer/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/prayer/APKBUILD')
-rw-r--r--testing/prayer/APKBUILD67
1 files changed, 67 insertions, 0 deletions
diff --git a/testing/prayer/APKBUILD b/testing/prayer/APKBUILD
new file mode 100644
index 000000000..2b6dc316e
--- /dev/null
+++ b/testing/prayer/APKBUILD
@@ -0,0 +1,67 @@
+# Maintainer:
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=prayer
+pkgver=1.3.5
+pkgrel=0
+pkgdesc='Lightweight webmail interface for IMAP servers'
+url='http://www-uxsup.csx.cam.ac.uk/~dpc22/prayer/'
+arch=all
+license=GPL
+depends=
+makedepends='perl imap-dev openssl-dev db-dev linux-pam-dev tar'
+subpackages=
+source="ftp://ftp.csx.cam.ac.uk/pub/software/email/prayer/prayer-$pkgver.tar.gz
+ buildfix.patch
+ disable_ssl3.patch
+ makefile_install_config.patch
+ no_db_version_check.patch
+ sighandling.patch
+ unbrand_accountd.patch
+ unbrand_cam_template.patch"
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ local i
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ BROOT="$pkgdir" make install
+}
+
+md5sums="e5c632e9abd517ee91f1f1cf5fb0eaf3 prayer-1.3.5.tar.gz
+8194a70b8def543ed2754ea8050fcc81 buildfix.patch
+479044ae50f58166ff3b101e9b0ca77e disable_ssl3.patch
+e5cfaee5abb3f92b5ad8b19cb31c4d10 makefile_install_config.patch
+7e241e9bd923ccd5deea254684f7023d no_db_version_check.patch
+4be579fda05ae887b1bbcd5c66145e68 sighandling.patch
+12117d22dfaaf74d68da235b31dec2fc unbrand_accountd.patch
+807ab15f361fe567047585da7451fac5 unbrand_cam_template.patch"
+sha256sums="aa79da17dceeb7eb24a1744e25286b3518eef882d8682f9959050d2bfb92ae8c prayer-1.3.5.tar.gz
+a8b483bcb9d951e992fa0679651758a48d0cb0c1b3e79e6b4168b0b8096fa25b buildfix.patch
+1b8bfb1a560434444992c3cfc050e59384f4737eb834aa2fe89e5f55ccc716e2 disable_ssl3.patch
+1b6baad865cfee27438ebf6a5e73a1d77dff611f02fcccb12da9ce5542f91b5c makefile_install_config.patch
+af65ba073614068bf3d7136d0193bcf870a9963c66a0adad163c4775573ae875 no_db_version_check.patch
+8a951fad98cffe4a12e52d6afc708b3e7e6b0f5ac2d4d4c8cb6d2a21bc770075 sighandling.patch
+22541d2f5c07660952b27f8389a2ff6240fddb28e09e2e3d93c7646154438180 unbrand_accountd.patch
+ed12c3cd3d6fff26823531b660edeee8b0fc8455f8fc9cffdccb76435bd55820 unbrand_cam_template.patch"
+sha512sums="6bb190fda2ac60c6f3801bc89eb719bea7b479c4417eb5e3315d95118dcfecceca9274fb0478360756d2f361d08ebf1f8176a393dbf1b5a3775a52f46e315be1 prayer-1.3.5.tar.gz
+ac7fc9e26871fd2e11e4e80bb0b6464f1262aa0b7298d043b5663da77c16b97174ac96214b2383432311a4ad6fbb4d35c4bbef0f5783be0462acf600ec15ee05 buildfix.patch
+ebb7710d9368aabeb8107f0cb16c399fb599345ff90fe3b8ae13a86949dd449ef13d7324048b9774183636c1581d1aa507053577608f9eff606b0d328e7ccf52 disable_ssl3.patch
+ce90bbf21d5b5b7eaad69d885012506dcee2386dd522899e1f4b9f7ad7906b050249faf329d7cf4e228735694fc201bef112fd7e2bdb4e19ad9cac3909fb73d1 makefile_install_config.patch
+a968e6cc3ce3c255918a0a520f7c81b0efaafcfd4fd548905167b11c69ce3b633524771af8fcb8866090e35fa1578db3158054bd8d06fd7d86e05e98d46c1e0a no_db_version_check.patch
+679cbdf560909005cc485317a2c35f4fe5c94eacb938996d58632a030d1a0f456e40ec883ded2a31879b20c9246fede2ead44c740768d1ab936c3a231c7ad8b2 sighandling.patch
+60c56f67e4b29b43973506f77837432d8e2449ea38ceb86b6b430c92af7023257740625bb3bedfe6bfa16d16c9dea73c523a98329e9415f5fc725861cc4de629 unbrand_accountd.patch
+cb230d3b1e64915a6843d72222a11d4d6aea1b5e27f6ba99870cb9011c41abcacbc30c183c19c706f26360001dbd38d3ea274393ddbb8d6d6bbf2661cf1f2568 unbrand_cam_template.patch"