summaryrefslogtreecommitdiffstats
path: root/testing/pure-ftpd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pure-ftpd/APKBUILD')
-rw-r--r--testing/pure-ftpd/APKBUILD53
1 files changed, 0 insertions, 53 deletions
diff --git a/testing/pure-ftpd/APKBUILD b/testing/pure-ftpd/APKBUILD
deleted file mode 100644
index 1717af866..000000000
--- a/testing/pure-ftpd/APKBUILD
+++ /dev/null
@@ -1,53 +0,0 @@
-# Contributor: Douglas Haber <me@douglashaber.com>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=pure-ftpd
-pkgver=1.0.32
-pkgrel=0
-pkgdesc="Pure FTPD FTP daemon"
-url="http://pureftpd.org"
-arch="all"
-license="GPL"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install=""
-subpackages=""
-source="http://download.pureftpd.org/pub/pure-ftpd/releases/$pkgname-$pkgver.tar.gz
- pure-ftpd.initd
- pure-ftpd.confd"
-
-_builddir="src/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure --prefix=/usr \
- --without-humor \
- --without-unicode \
- --with-minimal \
- --with-throttling \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- install -m755 -D ../$pkgname.initd \
- "$pkgdir"/etc/init.d/$pkgname || return 1
-
- install -m644 -D ../$pkgname.confd \
- "$pkgdir"/etc/conf.d/$pkgname || return 1
-}
-
-md5sums="a766eb36d537fd30217ffa129eb599b1 pure-ftpd-1.0.32.tar.gz
-4805788f4aeeb4efee64ddad0b526c3c pure-ftpd.initd
-5f1d2a2d353fc00bc39efa0ae6f1955f pure-ftpd.confd"