summaryrefslogtreecommitdiffstats
path: root/testing/py-inotify/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/py-inotify/APKBUILD')
-rw-r--r--testing/py-inotify/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/py-inotify/APKBUILD b/testing/py-inotify/APKBUILD
new file mode 100644
index 000000000..b07469cab
--- /dev/null
+++ b/testing/py-inotify/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-inotify
+_pkgname=pyinotify
+pkgver=0.9.4
+pkgrel=0
+pkgdesc="Linux filesystem events monitoring"
+url="http://pypi.python.org/pypi/pyinotify"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="701c91854d241514ede7ffe72086566d pyinotify-0.9.4.tar.gz"
+sha256sums="a09767e4e0610e2e1e9f9dc89483b0ee4a53764e700f5866a570bec51d003fec pyinotify-0.9.4.tar.gz"
+sha512sums="cdaf9f239a43e3889cdca0ebe1e3559bf6411e4cd829120cc2199cb91122bfe4af62f61a9bf297de28036716f974abd4d7bbeb210e22e96245781fbad08a2b75 pyinotify-0.9.4.tar.gz"