summaryrefslogtreecommitdiffstats
path: root/testing/pycrypto/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/pycrypto/APKBUILD')
-rw-r--r--testing/pycrypto/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/testing/pycrypto/APKBUILD b/testing/pycrypto/APKBUILD
index 1ed827ca9..f5a48e75c 100644
--- a/testing/pycrypto/APKBUILD
+++ b/testing/pycrypto/APKBUILD
@@ -1,17 +1,22 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pycrypto
pkgver=2.0.1
-pkgrel=0
+pkgrel=2
pkgdesc="A collection of cryptographic algorithms and protocols, implemented for use from Python."
url="http://www.amk.ca/python/code/crypto.html"
license="GPL"
depends="python"
-makedepends="gmp-dev python-dev"
+makedepends="gmp5-dev python-dev"
source="http://www.amk.ca/files/python/crypto/$pkgname-$pkgver.tar.gz"
build ()
{
cd "$srcdir"/$pkgname-$pkgver
- python setup.py build install --root="$pkgdir"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ python setup.py install --root="$pkgdir"
}
md5sums="4d5674f3898a573691ffb335e8d749cd pycrypto-2.0.1.tar.gz"