summaryrefslogtreecommitdiffstats
path: root/testing/wxformbuilder/libdl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'testing/wxformbuilder/libdl.patch')
-rw-r--r--testing/wxformbuilder/libdl.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/testing/wxformbuilder/libdl.patch b/testing/wxformbuilder/libdl.patch
index cc0be82ae..41aa10e38 100644
--- a/testing/wxformbuilder/libdl.patch
+++ b/testing/wxformbuilder/libdl.patch
@@ -1,11 +1,11 @@
---- ./src/Makefile.orig
-+++ ./src/Makefile
-@@ -5,6 +5,8 @@
- CONFIG=Release
- endif
-
-+LDFLAGS += -ldl
-+
- ifeq ($(CONFIG),Release)
- BINDIR := ../output/bin
- LIBDIR := ..
+--- ./src/premake.lua.orig
++++ ./src/premake.lua
+@@ -58,7 +58,7 @@
+ package.libpaths = { "../output/lib/wxformbuilder", "../sdk/lib" }
+ end
+ -- Set the libraries it links to.
+-package.links = { "wxFlatNotebook", "wxPropGrid", "wxScintilla", "TiCPP", "plugin-interface" }
++package.links = { "wxFlatNotebook", "wxPropGrid", "wxScintilla", "TiCPP", "plugin-interface", "dl" }
+
+ -- Add libraries and build options for stack trace in MinGW
+ if ( windows and ( (string.find( target or "", ".*-gcc" )) or (target == "gnu") ) ) then