summaryrefslogtreecommitdiffstats
path: root/unmaintained/kdesdk
diff options
context:
space:
mode:
Diffstat (limited to 'unmaintained/kdesdk')
-rw-r--r--unmaintained/kdesdk/APKBUILD42
-rw-r--r--unmaintained/kdesdk/not-glibc.patch12
2 files changed, 0 insertions, 54 deletions
diff --git a/unmaintained/kdesdk/APKBUILD b/unmaintained/kdesdk/APKBUILD
deleted file mode 100644
index b97385236..000000000
--- a/unmaintained/kdesdk/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer:
-pkgname=kdesdk
-pkgver=4.6.3
-pkgrel=1
-pkgdesc="software development tools for kde"
-url="http://www.kde.org/"
-#arch="all"
-license="GPL"
-depends=
-depends_dev="kdebase-workspace-dev hunspell-dev boost-dev perl-dev subversion-dev"
-makedepends="$depends_dev cmake automoc4"
-install=""
-subpackages="$pkgname-dev"
-source="http://kde.mirrors.tds.net/pub/kde/stable/$pkgver/src/kdesdk-$pkgver.tar.bz2
- not-glibc.patch"
-
-_builddir="$srcdir"/kdesdk-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- mkdir "$_builddir"/build
-}
-
-build() {
- cd "$_builddir"/build
- cmake -DCMAKE_INSTALL_PATH=/usr -DCMAKE_SKIP_RPATH=ON "$_builddir" || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"/build
- make DESTDIR="$pkgdir" install || return 1
-}
-
-md5sums="c4a223067a228688c6b62a6bdd67a022 kdesdk-4.6.3.tar.bz2
-00e1451447f9097a677c4606484077ca not-glibc.patch"
diff --git a/unmaintained/kdesdk/not-glibc.patch b/unmaintained/kdesdk/not-glibc.patch
deleted file mode 100644
index 646efb4f9..000000000
--- a/unmaintained/kdesdk/not-glibc.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- kdesdk-4.6.3.orig/CMakeLists.txt
-+++ kdesdk-4.6.3/CMakeLists.txt
-@@ -71,9 +71,7 @@
- #include <stdlib.h>
-
- int main() {
--#ifndef __GLIBC__
- choke me
--#endif
- return 0;
- }" LIBC_IS_GLIBC)
- if (LIBC_IS_GLIBC)