summaryrefslogtreecommitdiffstats
path: root/x11/dbus
diff options
context:
space:
mode:
Diffstat (limited to 'x11/dbus')
-rw-r--r--x11/dbus/APKBUILD37
-rw-r--r--x11/dbus/dbus.initd51
-rw-r--r--x11/dbus/dbus.pre-install4
3 files changed, 0 insertions, 92 deletions
diff --git a/x11/dbus/APKBUILD b/x11/dbus/APKBUILD
deleted file mode 100644
index 054db2787..000000000
--- a/x11/dbus/APKBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=dbus
-pkgver=1.2.16
-pkgrel=1
-pkgdesc="Freedesktop.org message bus system"
-url="http://www.freedesktop.org/Software/dbus"
-license="GPL custom"
-subpackages="$pkgname-dev $pkgname-doc"
-depends=
-makedepends="expat-dev libx11-dev pkgconfig util-linux-ng-dev"
-depends_dev="util-linux-ng-dev"
-install="$pkgname.pre-install"
-source="http://$pkgname.freedesktop.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
- $pkgname.initd
- "
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --with-xml=expat \
- --with-dbus-user=messagebus \
- --with-system-pid-file=/var/run/dbus.pid \
- --disable-verbose-mode \
- --disable-static \
- --enable-inotify \
- --disable-dnotify \
- --disable-tests \
- --disable-asserts \
- --with-x || return 1
- make || return 1
- make DESTDIR="$pkgdir" install
- install -Dm755 "$srcdir"/dbus.initd "$pkgdir"/etc/init.d/dbus
-}
-md5sums="c7a47b851ebe02f6726b65b78d1b730b dbus-1.2.16.tar.gz
-58356b4db650a89312a670c02804c540 dbus.initd"
diff --git a/x11/dbus/dbus.initd b/x11/dbus/dbus.initd
deleted file mode 100644
index e96ea05cd..000000000
--- a/x11/dbus/dbus.initd
+++ /dev/null
@@ -1,51 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/files/dbus.init-1.0,v 1.4 2007/04/04 13:35:25 cardoe Exp $
-
-opts="reload"
-
-depend() {
- need localmount
- after bootmisc
-}
-
-start() {
- ebegin "Starting D-BUS system messagebus"
-
- /usr/bin/dbus-uuidgen --ensure
-
- # We need to test if /var/run/dbus exists, since script will fail if it does not
- [ ! -e /var/run/dbus ] && mkdir /var/run/dbus
-
- start-stop-daemon --start --pidfile /var/run/dbus.pid --exec /usr/bin/dbus-daemon -- --system
- eend $?
-}
-
-stop() {
- local retval
-
- ebegin "Stopping D-BUS system messagebus"
-
- start-stop-daemon --stop --pidfile /var/run/dbus.pid
- retval=$?
-
- eend ${retval}
-
- [ -S /var/run/dbus/system_bus_socket ] && rm -f /var/run/dbus/system_bus_socket
-
- return ${retval}
-}
-
-reload() {
- local retval
-
- ebegin "Reloading D-BUS messagebus config"
-
- /usr/bin/dbus-send --print-reply --system --type=method_call \
- --dest=org.freedesktop.DBus \
- / org.freedesktop.DBus.ReloadConfig > /dev/null
- retval=$?
- eend ${retval}
- return ${retval}
-}
diff --git a/x11/dbus/dbus.pre-install b/x11/dbus/dbus.pre-install
deleted file mode 100644
index 515161db6..000000000
--- a/x11/dbus/dbus.pre-install
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-adduser -H -h /dev/null -s /bin/false -D messagebus 2>/dev/null
-exit 0