summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-03-25 08:06:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-03-25 08:06:18 +0000
commit004e11501ed52ff496278931517fe3f2db08b267 (patch)
tree390fb02094799a71f3fe6e9a37f4bc00fc3f8481
parentcc5f305aaba4cefe2227aef2550d565f2f5a8147 (diff)
downloadaports-004e11501ed52ff496278931517fe3f2db08b267.tar.bz2
aports-004e11501ed52ff496278931517fe3f2db08b267.tar.xz
main/lua-penlight: fix dependencies and license
-rw-r--r--main/lua-penlight/APKBUILD33
1 files changed, 23 insertions, 10 deletions
diff --git a/main/lua-penlight/APKBUILD b/main/lua-penlight/APKBUILD
index 3241a5a00..6cf524f67 100644
--- a/main/lua-penlight/APKBUILD
+++ b/main/lua-penlight/APKBUILD
@@ -1,15 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lua-penlight
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Lua libraries for extended operations on tables, lists and strings"
-url="http://penlight.luaforge.net/"
+url="http://stevedonovan.github.io/Penlight"
arch="noarch"
-license="GPL"
-depends="lua-filesystem"
+license="MIT"
+depends="lua5.1-penlight lua5.2-penlight"
makedepends=""
install=
-subpackages="$pkgname-doc lua5.1-penlight:_51 lua5.2-penlight:_52"
+subpackages="$pkgname-doc $pkgname-shared
+ lua5.1-penlight:_51
+ lua5.2-penlight:_52"
source="penlight-$pkgver.tar.gz::https://github.com/stevedonovan/Penlight/archive/$pkgver.tar.gz"
_builddir="$srcdir"/Penlight-$pkgver
@@ -22,23 +24,34 @@ build() {
package() {
cd "$_builddir"
- mkdir -p "$pkgdir"/usr/share/lua/5.1/ \
+ mkdir -p "$pkgdir"/usr/share/lua/common/ \
+ "$pkgdir"/usr/share/lua/5.1/ \
"$pkgdir"/usr/share/lua/5.2/ \
"$pkgdir"/usr/share/doc/$pkgname
- cp -r lua/pl "$pkgdir"/usr/share/lua/5.2/ || return 1
+ cp -r lua/pl "$pkgdir"/usr/share/lua/common/ || return 1
cp -r examples "$pkgdir"/usr/share/doc/$pkgname/
- ln -s ../5.2/pl "$pkgdir"/usr/share/lua/5.1/pl
+ ln -s ../common/pl "$pkgdir"/usr/share/lua/5.1/pl
+ ln -s ../common/pl "$pkgdir"/usr/share/lua/5.2/pl
+}
+
+shared() {
+ pkgdesc="penlight files that are shared for all supported Lua versions"
+ depends=
+ mkdir -p "$subpkgdir"/usr/share/lua/
+ mv "$pkgdir"/usr/share/lua/common "$subpkgdir"/usr/share/lua/
}
_52() {
- depends="$pkgname"
+ pkgdesc="Lua 5.2 libraries for extended operations on tables, lists and strings"
+ depends="lua-penlight-common lua5.2-filesystem"
mkdir -p "$subpkgdir"/usr/share/lua/
mv "$pkgdir"/usr/share/lua/5.2 "$subpkgdir"/usr/share/lua/
}
_51() {
+ pkgdesc="Lua 5.1 libraries for extended operations on tables, lists and strings"
replaces="lua-penlight"
- depends="lua5.2-penlight"
+ depends="lua-penlight-common lua5.1-filesystem"
mkdir -p "$subpkgdir"/usr/share/lua/
mv "$pkgdir"/usr/share/lua/5.1 "$subpkgdir"/usr/share/lua/
}