summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-21 14:57:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-21 14:58:42 +0000
commit0ada2778e513fb74a43644223a45a330eccf29e4 (patch)
tree164f9925e254f0c1d80e8e52d0a5b6bc9f56f4ad /main
parent463192d97f3b9bbbbfed43e1be39ed77ffccfe2f (diff)
downloadaports-0ada2778e513fb74a43644223a45a330eccf29e4.tar.bz2
aports-0ada2778e513fb74a43644223a45a330eccf29e4.tar.xz
main/lua-dbi: fix build for postgresql
Diffstat (limited to 'main')
-rw-r--r--main/lua-dbi/APKBUILD11
-rw-r--r--main/lua-dbi/lua-dbi-postgresql.patch9
2 files changed, 13 insertions, 7 deletions
diff --git a/main/lua-dbi/APKBUILD b/main/lua-dbi/APKBUILD
index ca97ac757..e39bf9ba3 100644
--- a/main/lua-dbi/APKBUILD
+++ b/main/lua-dbi/APKBUILD
@@ -3,7 +3,7 @@
pkgname=lua-dbi
_realname=luadbi
pkgver=0.5
-pkgrel=2
+pkgrel=3
pkgdesc="A database interface library for Lua"
url="http://code.google.com/p/luadbi"
arch="all"
@@ -13,7 +13,8 @@ makedepends="lua-dev mysql-dev postgresql-dev sqlite-dev"
install=""
subpackages="$pkgname-mysql $pkgname-postgresql $pkgname-sqlite"
source="http://luadbi.googlecode.com/files/$_realname.$pkgver.tar.gz
- lua-dbi-postgresql.patch"
+ lua-dbi-postgresql.patch
+ "
_builddir="$srcdir"
@@ -63,4 +64,8 @@ postgresql() {
}
md5sums="ede2b003aadddc151aac87050c3d926e luadbi.0.5.tar.gz
-67fa36ca81d2d7003be5a3f86d35c79c lua-dbi-postgresql.patch"
+2424dcd34af6b25016c6a875c61c266b lua-dbi-postgresql.patch"
+sha256sums="49116458dd80052536bf5d7e2b2a1f5a0fa42a671ce77f1cb7355ef7faeb331e luadbi.0.5.tar.gz
+f52a643b8e2b3680d2804683c08ddc451f41881d896e8600d9253de0d6903f48 lua-dbi-postgresql.patch"
+sha512sums="4ed641e113e90acc8a4f6b3b2d0f5d5044c0fbbef3b2fdfb84d15e17115e45c553a33b19bfb165e5af11a2adce501d66859963e3363d3ab1c6a39b0b2ae92e62 luadbi.0.5.tar.gz
+091b9a09999a89481ee09ad3f6f841417ed5edcf9324bae4a33ec0cd7290f612fe1d60fb56f76a2b8954d0d7d9f1495ffca8676cb7ed1dc8e93408658fd331db lua-dbi-postgresql.patch"
diff --git a/main/lua-dbi/lua-dbi-postgresql.patch b/main/lua-dbi/lua-dbi-postgresql.patch
index 2d2ba272d..d09ce004e 100644
--- a/main/lua-dbi/lua-dbi-postgresql.patch
+++ b/main/lua-dbi/lua-dbi-postgresql.patch
@@ -1,9 +1,10 @@
---- a/dbd/postgresql/dbd_postgresql.h.old 2010-05-01 06:25:12.000000000 +0200
-+++ b/dbd/postgresql/dbd_postgresql.h 2011-04-19 16:59:53.364944209 +0200
-@@ -1,5 +1,5 @@
+diff --git a/dbd/postgresql/dbd_postgresql.h b/dbd/postgresql/dbd_postgresql.h
+index b3e18f9..1ff6ffb 100755
+--- a/dbd/postgresql/dbd_postgresql.h
++++ b/dbd/postgresql/dbd_postgresql.h
+@@ -1,5 +1,4 @@
#include <libpq-fe.h>
-#include <postgres_fe.h>
-+#include <server/postgres_fe.h>
#include <dbd/common.h>
/*