summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-21 11:04:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-21 11:04:29 +0000
commit60a0de4d1cbb6799456b1a72665286289f7aa82c (patch)
treebc9577070fcf7f8cf8a9630b88b3111b5de4b62e /main
parent66d2914aa9ac00af4fd4ab2b8be232fff6f7f022 (diff)
downloadaports-60a0de4d1cbb6799456b1a72665286289f7aa82c.tar.bz2
aports-60a0de4d1cbb6799456b1a72665286289f7aa82c.tar.xz
main/epdfview: dead upstream
https://lists.fedoraproject.org/pipermail/devel/2013-February/178580.html
Diffstat (limited to 'main')
-rw-r--r--main/epdfview/APKBUILD67
-rw-r--r--main/epdfview/epdfview-0.1.8-cups-1.6.patch73
-rw-r--r--main/epdfview/epdfview-0.1.8-glib-2.31-build-fix.patch11
-rw-r--r--main/epdfview/epdfview-0.1.8-swap-colors-with-poppler-0.18.patch50
-rw-r--r--main/epdfview/epdfview.desktop.patch11
-rw-r--r--main/epdfview/fix-scrolling.patch33
6 files changed, 0 insertions, 245 deletions
diff --git a/main/epdfview/APKBUILD b/main/epdfview/APKBUILD
deleted file mode 100644
index 75e9c6b94..000000000
--- a/main/epdfview/APKBUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=epdfview
-pkgver=0.1.8
-pkgrel=8
-pkgdesc="A free lightweight PDF document viewer."
-url="http://www.emma-soft.com/projects/epdfview/"
-arch="all"
-license="GPL"
-depends="desktop-file-utils hicolor-icon-theme"
-makedepends="poppler-dev gtk+2.0-dev cups-dev autoconf automake"
-subpackages="$pkgname-lang"
-source="http://www.emma-soft.com/projects/$pkgname/chrome/site/releases/$pkgname-$pkgver.tar.bz2
- $pkgname.desktop.patch
- epdfview-0.1.8-glib-2.31-build-fix.patch
- epdfview-0.1.8-swap-colors-with-poppler-0.18.patch
- epdfview-0.1.8-cups-1.6.patch
- "
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch)
- msg "$i"
- patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
- # make automake happy
- touch ChangeLog
-
- aclocal -I m4 && autoconf && automake --add-missing && autoheader
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
- for i in 24 32 48; do
- install -d "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps \
- || return 1
- done
- install -m644 data/icon_epdfview-24.png \
- "$pkgdir"/usr/share/icons/hicolor/24x24/apps/epdfview.png
- install -m644 data/icon_epdfview-32.png \
- "$pkgdir"/usr/share/icons/hicolor/32x32/apps/epdfview.png
- install -m644 data/icon_epdfview-48.png \
- "$pkgdir"/usr/share/icons/hicolor/48x48/apps/epdfview.png
-}
-
-md5sums="e50285b01612169b2594fea375f53ae4 epdfview-0.1.8.tar.bz2
-c87ed492dcf64a0b41476989c9282f8b epdfview.desktop.patch
-6e52b4bd6996530443eb4477c6f21e3f epdfview-0.1.8-glib-2.31-build-fix.patch
-c823d279a77a983fe29290c6db2e1881 epdfview-0.1.8-swap-colors-with-poppler-0.18.patch
-113bdf270dec17a7bd59ee990e7c0491 epdfview-0.1.8-cups-1.6.patch"
diff --git a/main/epdfview/epdfview-0.1.8-cups-1.6.patch b/main/epdfview/epdfview-0.1.8-cups-1.6.patch
deleted file mode 100644
index 7ad27011c..000000000
--- a/main/epdfview/epdfview-0.1.8-cups-1.6.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-diff -Naur epdfview-0.1.8.orig/src/PrintPter.cxx epdfview-0.1.8/src/PrintPter.cxx
---- epdfview-0.1.8.orig/src/PrintPter.cxx 2011-05-28 11:25:01.000000000 +0100
-+++ epdfview-0.1.8/src/PrintPter.cxx 2012-08-22 20:11:46.362436859 +0100
-@@ -22,6 +22,40 @@
- #include <locale.h>
- #include "epdfview.h"
-
-+#if (CUPS_VERSION_MAJOR > 1) || (CUPS_VERSION_MINOR > 5)
-+#define HAVE_CUPS_1_6 1
-+#endif
-+
-+#ifndef HAVE_CUPS_1_6
-+inline int ippGetInteger (ipp_attribute_t *attr, int element)
-+{
-+ return (attr->values[element].integer);
-+}
-+
-+inline const char * ippGetString (ipp_attribute_t *attr,
-+ int element,
-+ const char **language /*UNUSED*/)
-+{
-+ return (attr->values[element].string.text);
-+}
-+
-+inline int ippSetOperation (ipp_t *ipp, ipp_op_t op)
-+{
-+ if (!ipp)
-+ return (0);
-+ ipp->request.op.operation_id = op;
-+ return (1);
-+}
-+
-+inline int ippSetRequestId (ipp_t *ipp, int request_id)
-+{
-+ if (!ipp)
-+ return (0);
-+ ipp->request.any.request_id = request_id;
-+ return (1);
-+}
-+#endif
-+
- using namespace ePDFView;
-
- // Structures
-@@ -380,8 +414,8 @@
-
- ipp_t *request = ippNew ();
-
-- request->request.op.operation_id = IPP_GET_PRINTER_ATTRIBUTES;
-- request->request.op.request_id = 1;
-+ ippSetOperation(request, IPP_GET_PRINTER_ATTRIBUTES);
-+ ippSetRequestId(request, 1);
-
- ippAddString (request, IPP_TAG_OPERATION, IPP_TAG_CHARSET,
- "attributes-charset", NULL, "utf-8");
-@@ -403,7 +437,7 @@
- ippFindAttribute (answer, "printer-state", IPP_TAG_ZERO);
- if ( NULL != state )
- {
-- switch (state->values[0].integer)
-+ switch (ippGetInteger (state, 0))
- {
- case IPP_PRINTER_IDLE:
- attributes->state = g_strdup (_("Idle"));
-@@ -425,7 +459,7 @@
- ippFindAttribute (answer, "printer-location", IPP_TAG_ZERO);
- if ( NULL != location )
- {
-- attributes->location = g_strdup (location->values[0].string.text);
-+ attributes->location = g_strdup (ippGetString (location, 0, NULL));
- }
-
- ippDelete (answer);
diff --git a/main/epdfview/epdfview-0.1.8-glib-2.31-build-fix.patch b/main/epdfview/epdfview-0.1.8-glib-2.31-build-fix.patch
deleted file mode 100644
index 6e7f20460..000000000
--- a/main/epdfview/epdfview-0.1.8-glib-2.31-build-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-Index: trunk/src/gtk/StockIcons.h
-===================================================================
---- trunk/src/gtk/StockIcons.h (revision 325)
-+++ trunk/src/gtk/StockIcons.h (revision 369)
-@@ -19,5 +19,5 @@
- #define __STOCK_ICONS_H__
-
--#include <glib/gmacros.h>
-+#include <glib.h>
-
- G_BEGIN_DECLS
diff --git a/main/epdfview/epdfview-0.1.8-swap-colors-with-poppler-0.18.patch b/main/epdfview/epdfview-0.1.8-swap-colors-with-poppler-0.18.patch
deleted file mode 100644
index c93d1e5f3..000000000
--- a/main/epdfview/epdfview-0.1.8-swap-colors-with-poppler-0.18.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Swap color channels to fix pictures with poppler 0.18
-
-Upstream: http://trac.emma-soft.com/epdfview/changeset/367/trunk
-Fixes bug: https://bugzilla.redhat.com/show_bug.cgi?id=745483
-
-Index: src/PDFDocument.cxx
-===================================================================
---- ./src/PDFDocument.cxx (revision 366)
-+++ ./src/PDFDocument.cxx (revision 367)
-@@ -20,6 +20,7 @@
- #include <time.h>
- #include <poppler.h>
- #include <unistd.h>
-+#include <algorithm>
- #include "epdfview.h"
-
- using namespace ePDFView;
-@@ -33,6 +34,24 @@
- static PageMode convertPageMode (gint pageMode);
- static gchar *getAbsoluteFileName (const gchar *fileName);
-
-+namespace
-+{
-+ void
-+ convert_bgra_to_rgba (guint8 *data, int width, int height)
-+ {
-+ using std::swap;
-+
-+ for (int y = 0; y < height; y++)
-+ {
-+ for (int x = 0; x < width; x++)
-+ {
-+ swap(data[0], data[2]);
-+ data += 4;
-+ }
-+ }
-+ }
-+}
-+
- ///
- /// @brief Constructs a new PDFDocument object.
- ///
-@@ -650,6 +669,7 @@
- poppler_page_render (page, context);
- cairo_destroy(context);
- cairo_surface_destroy (surface);
-+ convert_bgra_to_rgba(renderedPage->getData (), width, height);
- #else // !HAVE_POPPLER_0_17_0
- // Create the pixbuf from the data and render to it.
- GdkPixbuf *pixbuf = gdk_pixbuf_new_from_data (renderedPage->getData (),
diff --git a/main/epdfview/epdfview.desktop.patch b/main/epdfview/epdfview.desktop.patch
deleted file mode 100644
index 93dbc03d4..000000000
--- a/main/epdfview/epdfview.desktop.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/data/epdfview.desktop.bak 2009-04-05 16:55:56.000000000 -0700
-+++ b/data/epdfview.desktop 2009-04-05 16:56:33.000000000 -0700
-@@ -7,7 +7,7 @@
- GenericName=PDF Viewer
- GenericName[ca]=Visor PDF
- GenericName[es]=Visor PDF
--Icon=icon_epdfview-48
-+Icon=epdfview
- Name=ePDFViewer
- Name[ca]=ePDFViewer
- Name[es]=ePDFViewer
diff --git a/main/epdfview/fix-scrolling.patch b/main/epdfview/fix-scrolling.patch
deleted file mode 100644
index 828bf1258..000000000
--- a/main/epdfview/fix-scrolling.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- ./src/gtk/MainView.cxx.old 2009-02-28 22:00:55.000000000 +0100
-+++ ./src/gtk/MainView.cxx 2009-03-20 03:12:10.000000000 +0100
-@@ -77,7 +77,7 @@
- static void main_window_zoom_out_cb (GtkWidget *, gpointer);
- static void main_window_zoom_width_cb (GtkToggleAction *, gpointer);
- static void main_window_set_page_mode (GtkRadioAction *, GtkRadioAction *, gpointer);
--static void main_window_page_scrolled_cb (GtkWidget *widget, GdkEventScroll *event, gpointer data);
-+static gboolean main_window_page_scrolled_cb (GtkWidget *widget, GdkEventScroll *event, gpointer data);
-
- #if defined (HAVE_CUPS)
- static void main_window_print_cb (GtkWidget *, gpointer);
-@@ -1479,18 +1479,19 @@
- pter->setPageMode (mode);
- }
-
--void
-+gboolean
- main_window_page_scrolled_cb (GtkWidget *widget, GdkEventScroll *event, gpointer data)
- {
- g_assert ( NULL != data && "The data parameter is NULL.");
-
- MainPter *pter = (MainPter *)data;
- // Only zoom when the CTRL-Button is down...
-- if ( !(event->state & GDK_CONTROL_MASK) ) return;
-+ if ( !(event->state & GDK_CONTROL_MASK) ) return FALSE;
- if ( event->direction == GDK_SCROLL_UP ) {
- pter->zoomInActivated ();
- } else if ( event->direction == GDK_SCROLL_DOWN ) {
- pter->zoomOutActivated ();
- }
-+ return TRUE;
- }
-