summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-20 20:09:50 +0300
committerTimo Teräs <timo.teras@iki.fi>2013-10-20 20:09:50 +0300
commitb3cd6c73bb3d082a545a9d15d119180fc3b1972b (patch)
treec6ade00965d3778aebf04b49da977fd9c8294e41 /main
parent846c523146995c5a8cf777bb65d08251287635cf (diff)
downloadaports-b3cd6c73bb3d082a545a9d15d119180fc3b1972b.tar.bz2
aports-b3cd6c73bb3d082a545a9d15d119180fc3b1972b.tar.xz
main/binutils: keep libiberty.a in normal build
some applications need it
Diffstat (limited to 'main')
-rw-r--r--main/binutils/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/binutils/APKBUILD b/main/binutils/APKBUILD
index 492adb134..fcd904756 100644
--- a/main/binutils/APKBUILD
+++ b/main/binutils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=binutils
pkgver=2.23.2
-pkgrel=3
+pkgrel=4
pkgdesc="Tools necessary to build programs"
url="http://www.gnu.org/software/binutils/"
depends=
@@ -66,11 +66,11 @@ package() {
mv "$pkgdir"/usr/lib64/* "$pkgdir"/usr/lib/
rmdir "$pkgdir"/usr/lib64
fi
- rm "$pkgdir"/usr/lib/libiberty.a
if [ "$CHOST" != "$CTARGET" ]; then
# creating cross tools: remove any files that would conflict
# with the native tools, or other cross tools
rm -r "$pkgdir"/usr/share
+ rm -f "$pkgdir"/usr/lib/libiberty.a
fi
find "$pkgdir" -name "*.la" -delete
}