summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-12-11 13:37:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-12-11 13:38:14 +0000
commitbc0c3bd7cfa15f3fa521634b2be18fcf7a25ace8 (patch)
tree0f50f7ca72f8c0a99ab234dd5f7fc1d999a673ec /main
parentf3dcfdf3632a1b9ea975c80c78c6402eb5d4a8e7 (diff)
downloadaports-bc0c3bd7cfa15f3fa521634b2be18fcf7a25ace8.tar.bz2
aports-bc0c3bd7cfa15f3fa521634b2be18fcf7a25ace8.tar.xz
main/libvpx: fix permissions
Diffstat (limited to 'main')
-rw-r--r--main/libvpx/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/libvpx/APKBUILD b/main/libvpx/APKBUILD
index 5b4e5d66d..660926ae7 100644
--- a/main/libvpx/APKBUILD
+++ b/main/libvpx/APKBUILD
@@ -2,7 +2,7 @@
pkgname=libvpx
pkgver=1.3.0
_ver=${pkgver/_/-}
-pkgrel=1
+pkgrel=2
pkgdesc="Library for the vp8 codec"
url="http://www.webmproject.org/"
arch="all"
@@ -42,7 +42,8 @@ build() {
package() {
cd "$_builddir"
make DIST_DIR="$pkgdir"/usr install
- chmod 644 "$pkgdir"/usr/include/vpx/*.h || return 1
+ chmod 644 "$pkgdir"/usr/include/vpx/*.h \
+ "$pkgdir"/usr/lib/pkgconfig/* || return 1
chown root:root -R "$pkgdir" || return 1
chmod 755 "$pkgdir"/usr/lib/* || return 1
}