summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-03-14 10:05:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-03-14 10:05:00 +0000
commitc44818aa664a2f5f3f9f70fe92f20db1ee11d8a7 (patch)
tree303a1165e306d06800927e01d8a61690eecae3e5 /main
parent9f732c02548dee0e47ea1d6a004f63debe48d03a (diff)
downloadaports-c44818aa664a2f5f3f9f70fe92f20db1ee11d8a7.tar.bz2
aports-c44818aa664a2f5f3f9f70fe92f20db1ee11d8a7.tar.xz
main/bluez: upgrade to 5.16
Diffstat (limited to 'main')
-rw-r--r--main/bluez/0001-shared-include-endian.h-for-be32toh-htobe32-and-htob.patch49
-rw-r--r--main/bluez/0002-unit-prevent-unintended-use-of-glibc-s-error-3.patch64
-rw-r--r--main/bluez/0002-various-header-include-fixes-for-building-with-musl-.patch54
-rw-r--r--main/bluez/0003-bnep-avoid-use-of-caddr_t.patch (renamed from main/bluez/0001-bnep-avoid-use-of-caddr_t.patch)17
-rw-r--r--main/bluez/0003-unit-prevent-use-of-glibc-s-error-3.patch34
-rw-r--r--main/bluez/APKBUILD37
6 files changed, 143 insertions, 112 deletions
diff --git a/main/bluez/0001-shared-include-endian.h-for-be32toh-htobe32-and-htob.patch b/main/bluez/0001-shared-include-endian.h-for-be32toh-htobe32-and-htob.patch
new file mode 100644
index 000000000..53eaf7763
--- /dev/null
+++ b/main/bluez/0001-shared-include-endian.h-for-be32toh-htobe32-and-htob.patch
@@ -0,0 +1,49 @@
+From 16fc9188b9de0e15454a31072b9636b9fa683d89 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Fri, 14 Mar 2014 07:27:33 +0000
+Subject: [PATCH 1/3] shared: include endian.h for be32toh, htobe32 and htobe64
+ functions
+
+The man page says that #include <endian.h> is needed for those.
+
+This fixes the following compile error when building with musl libc on
+Alpine Linux:
+
+src/shared/btsnoop.o: In function `btsnoop_write':
+.../src/bluez/src/shared/btsnoop.c:208: undefined reference to `htobe32'
+.../src/bluez/src/shared/btsnoop.c:209: undefined reference to `htobe32'
+.../src/bluez/src/shared/btsnoop.c:210: undefined reference to `htobe32'
+.../src/bluez/src/shared/btsnoop.c:211: undefined reference to `htobe32'
+.../src/bluez/src/shared/btsnoop.c:212: undefined reference to `htobe64'
+src/shared/btsnoop.o: In function `btsnoop_open':
+.../src/bluez/src/shared/btsnoop.c:100: undefined reference to `be32toh'
+.../src/bluez/src/shared/btsnoop.c:103: undefined reference to `be32toh'
+src/shared/btsnoop.o: In function `btsnoop_create':
+.../src/bluez/src/shared/btsnoop.c:151: undefined reference to `htobe32'
+.../src/bluez/src/shared/btsnoop.c:152: undefined reference to `htobe32'
+src/shared/btsnoop.o: In function `pklg_read_hci':
+.../src/bluez/src/shared/btsnoop.c:336: undefined reference to `be32toh'
+.../src/bluez/src/shared/btsnoop.c:338: undefined reference to `be64toh'
+src/shared/btsnoop.o: In function `btsnoop_read_hci':
+.../src/bluez/src/shared/btsnoop.c:416: undefined reference to `be32toh'
+.../src/bluez/src/shared/btsnoop.c:417: undefined reference to `be32toh'
+.../src/bluez/src/shared/btsnoop.c:419: undefined reference to `be64toh'
+---
+ src/shared/btsnoop.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/shared/btsnoop.c b/src/shared/btsnoop.c
+index d2b3b4b..17a872c 100644
+--- a/src/shared/btsnoop.c
++++ b/src/shared/btsnoop.c
+@@ -25,6 +25,7 @@
+ #include <config.h>
+ #endif
+
++#include <endian.h>
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <stdlib.h>
+--
+1.9.0
+
diff --git a/main/bluez/0002-unit-prevent-unintended-use-of-glibc-s-error-3.patch b/main/bluez/0002-unit-prevent-unintended-use-of-glibc-s-error-3.patch
new file mode 100644
index 000000000..c4478b709
--- /dev/null
+++ b/main/bluez/0002-unit-prevent-unintended-use-of-glibc-s-error-3.patch
@@ -0,0 +1,64 @@
+From ca6bd966bca447c9e5f914f56a1432c7b695b251 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 21 Jan 2014 21:06:03 +0000
+Subject: [PATCH 2/3] unit: prevent unintended use of glibc's error(3)
+
+When building the test-sdp we don't want src/sdpd-request.c end up
+using the incompatible GNU libc's error(3) instead of the intended
+src/log.c's error().
+
+This also fixes the following compile error on Alpine Linux with musl
+libc which does not implement the error(3) GNU extension:
+
+src/sdpd-request.o: In function `extract_des':
+/home/ncopa/src/bluez/src/sdpd-request.c:126: undefined reference to `error'
+src/sdpd-request.o: In function `process_request':
+/home/ncopa/src/bluez/src/sdpd-request.c:1022: undefined reference to `error'
+/home/ncopa/src/bluez/src/sdpd-request.c:1045: undefined reference to `error'
+---
+ Makefile.am | 1 +
+ unit/test-sdp.c | 9 +++------
+ 2 files changed, 4 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index fb11230..700b956 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -265,6 +265,7 @@ unit_tests += unit/test-sdp
+ unit_test_sdp_SOURCES = unit/test-sdp.c \
+ src/shared/util.h src/shared/util.c \
+ src/sdpd.h src/sdpd-database.c \
++ src/log.h src/log.c \
+ src/sdpd-service.c src/sdpd-request.c
+ unit_test_sdp_LDADD = lib/libbluetooth-internal.la @GLIB_LIBS@
+
+diff --git a/unit/test-sdp.c b/unit/test-sdp.c
+index 9b82343..853576d 100644
+--- a/unit/test-sdp.c
++++ b/unit/test-sdp.c
+@@ -128,12 +128,6 @@ static void sdp_debug(const char *str, void *user_data)
+ g_print("%s%s\n", prefix, str);
+ }
+
+-void btd_debug(const char *format, ...);
+-
+-void btd_debug(const char *format, ...)
+-{
+-}
+-
+ static void context_quit(struct context *context)
+ {
+ g_main_loop_quit(context->main_loop);
+@@ -797,6 +791,9 @@ int main(int argc, char *argv[])
+ {
+ g_test_init(&argc, &argv, NULL);
+
++ if (g_test_verbose())
++ __btd_log_init("*", 0);
++
+ /*
+ * Service Search Request
+ *
+--
+1.9.0
+
diff --git a/main/bluez/0002-various-header-include-fixes-for-building-with-musl-.patch b/main/bluez/0002-various-header-include-fixes-for-building-with-musl-.patch
deleted file mode 100644
index bc58dba92..000000000
--- a/main/bluez/0002-various-header-include-fixes-for-building-with-musl-.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From e85ee33b48ce92dfe315286089f333fcb1f83512 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 17 Jan 2014 10:11:52 +0000
-Subject: [PATCH 2/3] various header include fixes for building with musl libc
-
-we need:
- sys/stat.h for mode_t
- limits.h for PATH_MAX
----
- src/textfile.h | 2 ++
- tools/csr_usb.c | 1 +
- tools/hid2hci.c | 1 +
- 3 files changed, 4 insertions(+)
-
-diff --git a/src/textfile.h b/src/textfile.h
-index b779bd2..e26da5d 100644
---- a/src/textfile.h
-+++ b/src/textfile.h
-@@ -24,6 +24,8 @@
- #ifndef __TEXTFILE_H
- #define __TEXTFILE_H
-
-+#include <sys/stat.h>
-+
- int create_file(const char *filename, const mode_t mode);
- int create_name(char *buf, size_t size, const char *path,
- const char *address, const char *name);
-diff --git a/tools/csr_usb.c b/tools/csr_usb.c
-index a483bc1..5fb6bdc 100644
---- a/tools/csr_usb.c
-+++ b/tools/csr_usb.c
-@@ -33,6 +33,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <dirent.h>
-+#include <limits.h>
- #include <sys/ioctl.h>
-
- #include "csr.h"
-diff --git a/tools/hid2hci.c b/tools/hid2hci.c
-index 95b4abf..2dbfca7 100644
---- a/tools/hid2hci.c
-+++ b/tools/hid2hci.c
-@@ -35,6 +35,7 @@
- #include <string.h>
- #include <dirent.h>
- #include <getopt.h>
-+#include <limits.h>
- #include <sys/ioctl.h>
- #include <linux/types.h>
- #include <linux/hiddev.h>
---
-1.8.5.3
-
diff --git a/main/bluez/0001-bnep-avoid-use-of-caddr_t.patch b/main/bluez/0003-bnep-avoid-use-of-caddr_t.patch
index 8a6dbe88f..c6c6ddd19 100644
--- a/main/bluez/0001-bnep-avoid-use-of-caddr_t.patch
+++ b/main/bluez/0003-bnep-avoid-use-of-caddr_t.patch
@@ -1,20 +1,23 @@
-From 01fa57588b6e1eba85c113335e9c599b725748cb Mon Sep 17 00:00:00 2001
+From 9f4a63e594d676bd116c2d067db0a2a1d37e5f33 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Fri, 17 Jan 2014 10:08:50 +0000
-Subject: [PATCH 1/3] bnep: avoid use of caddr_t
+Subject: [PATCH 3/3] bnep: avoid use of caddr_t
caddr_t is legacy BSD and should be avoided.
-This fixes building against musl libc.
+This fixes the following compile error on Alpine Linux with musl libc:
+profiles/network/bnep.c: In function 'bnep_if_up':
+profiles/network/bnep.c:205:33: error: 'caddr_t' undeclared (first use in this function)
+ err = ioctl(sk, SIOCSIFFLAGS, (caddr_t) &ifr);
---
profiles/network/bnep.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/profiles/network/bnep.c b/profiles/network/bnep.c
-index 2a74016..4f9b801 100644
+index ece979f..b93027a 100644
--- a/profiles/network/bnep.c
+++ b/profiles/network/bnep.c
-@@ -202,7 +202,7 @@ static int bnep_if_up(const char *devname)
+@@ -204,7 +204,7 @@ static int bnep_if_up(const char *devname)
ifr.ifr_flags |= IFF_UP;
ifr.ifr_flags |= IFF_MULTICAST;
@@ -23,7 +26,7 @@ index 2a74016..4f9b801 100644
close(sk);
-@@ -227,7 +227,7 @@ static int bnep_if_down(const char *devname)
+@@ -229,7 +229,7 @@ static int bnep_if_down(const char *devname)
ifr.ifr_flags &= ~IFF_UP;
/* Bring down the interface */
@@ -33,5 +36,5 @@ index 2a74016..4f9b801 100644
close(sk);
--
-1.8.5.3
+1.9.0
diff --git a/main/bluez/0003-unit-prevent-use-of-glibc-s-error-3.patch b/main/bluez/0003-unit-prevent-use-of-glibc-s-error-3.patch
deleted file mode 100644
index 7a9a9a9ff..000000000
--- a/main/bluez/0003-unit-prevent-use-of-glibc-s-error-3.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 91e3e5dee411d4af864cc81e108e0e75c1d7e846 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 17 Jan 2014 10:39:16 +0000
-Subject: [PATCH 3/3] unit: prevent use of glibc's error(3)
-
-When building the test-sdp we don't want src/sdpd-request.c end up
-using the incompatible GNU libc's error(3).
-
-This also fixes building on musl libc which misses the error(3) GNU
-extension.
----
- unit/test-sdp.c | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/unit/test-sdp.c b/unit/test-sdp.c
-index 6d699e2..eeed0cb 100644
---- a/unit/test-sdp.c
-+++ b/unit/test-sdp.c
-@@ -134,6 +134,12 @@ void btd_debug(const char *format, ...)
- {
- }
-
-+void error(const char *format, ...);
-+
-+void error(const char *format, ...)
-+{
-+}
-+
- static void context_quit(struct context *context)
- {
- g_main_loop_quit(context->main_loop);
---
-1.8.5.3
-
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index b594ddf03..832545780 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
-pkgver=5.14
+pkgver=5.16
pkgrel=0
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
@@ -9,13 +9,15 @@ license="GPL2+"
depends="consolekit dbus"
replaces="udev"
makedepends="dbus-dev libusb-compat-dev udev-dev
- libical-dev readline-dev glib-dev"
+ libical-dev readline-dev glib-dev
+ autoconf automake libtool
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-cups
$pkgname-hid2hci"
source="http://www.kernel.org/pub/linux/bluetooth/bluez-$pkgver.tar.xz
- 0001-bnep-avoid-use-of-caddr_t.patch
- 0002-various-header-include-fixes-for-building-with-musl-.patch
- 0003-unit-prevent-use-of-glibc-s-error-3.patch
+ 0001-shared-include-endian.h-for-be32toh-htobe32-and-htob.patch
+ 0002-unit-prevent-unintended-use-of-glibc-s-error-3.patch
+ 0003-bnep-avoid-use-of-caddr_t.patch
bluetooth.initd
rfcomm.initd
rfcomm.confd
@@ -29,6 +31,7 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ libtoolize --force && aclocal && autoconf && automake --add-missing
}
build() {
@@ -73,24 +76,24 @@ hid2hci() {
mv "$pkgdir"/lib "$subpkgdir"/
}
-md5sums="81f2ce3bc9a9ebe58ccfce6660031611 bluez-5.14.tar.xz
-fb06db3798d26e6c443569415935f2d9 0001-bnep-avoid-use-of-caddr_t.patch
-f82f9f649cba62fef728fec5be24d8f7 0002-various-header-include-fixes-for-building-with-musl-.patch
-4420901a298a935b1619bf2d0cd834b9 0003-unit-prevent-use-of-glibc-s-error-3.patch
+md5sums="4cf4e60e5eaed8eaf42caa816d356ca1 bluez-5.16.tar.xz
+983fa9455a969e0df38ddbe9ab460917 0001-shared-include-endian.h-for-be32toh-htobe32-and-htob.patch
+1d87b1ed2603eb37ae96d4368192737a 0002-unit-prevent-unintended-use-of-glibc-s-error-3.patch
+e320ccd2ec08d81018ed4f92f198bf66 0003-bnep-avoid-use-of-caddr_t.patch
7a5611fa2cf42da2e844f96b2efa9f3b bluetooth.initd
7672edb8e33c4495ee9febb9864feb10 rfcomm.initd
7f4bb093adb0f519c621f2ea68712f35 rfcomm.confd"
-sha256sums="5a485837c215f3093d3a98cb412dc99e1139f88a66c8809bdf183ad5e676395f bluez-5.14.tar.xz
-b923cd59e639bac2b59ea40b29c95aaa4b5d741317fc76b25b37ead614fe65cd 0001-bnep-avoid-use-of-caddr_t.patch
-bbec3ba7559d8382f64aaae77c26fdca9c702d4a6a6d79d2420c9c76efd7fa3f 0002-various-header-include-fixes-for-building-with-musl-.patch
-1f249b7f62215dee882bc0e1a8d9e9dfe743df348c32d0bb05b4e47bad48ab79 0003-unit-prevent-use-of-glibc-s-error-3.patch
+sha256sums="c8d5094a21a799dca9cdcd99651dc19d521af514b22b8178fc787c454cdbb163 bluez-5.16.tar.xz
+3ec238c343466e5f835365c2d9fa7d3039fc22b9a40bc98aa3f8dda4a2bccf50 0001-shared-include-endian.h-for-be32toh-htobe32-and-htob.patch
+d1a7018c0971ad52d31b6eb6231deb86de5f913d0a6661992716c6a797c2c1bc 0002-unit-prevent-unintended-use-of-glibc-s-error-3.patch
+6d3c08dd9ddd2c16b74a0e4039c336a2b78dbb2e5b7a54e040ebfb76009a065e 0003-bnep-avoid-use-of-caddr_t.patch
d4aef203e184bef4284b3719268c91e07a1e3f84cbdea2ac8ab40a2617ac9186 bluetooth.initd
4430703a9bec9a9482416b2d24aa47492264768a0b61356b361bbc8b1229a83e rfcomm.initd
672498957049fd301f9c9c1dc9fa49430e5e6d3c3f1f3cdce80df3af7d425d08 rfcomm.confd"
-sha512sums="41ff320157b034f1b075266d8a6e0ffc9a2eccb2a4ae90abaec0970abd144a3e536292e826bd47f82e7fd52c1d370d45fba537f54e5cb8d6e9e306ab30f4af0f bluez-5.14.tar.xz
-a2f6e21fb0285b4438a146260c1b0953b6623d0ab4040765f2e2d342934390180e4ce2ae0c55a994052bf2c489152d259691a2053a8cbbfe6d66e8af5849592b 0001-bnep-avoid-use-of-caddr_t.patch
-c5916edb49970faa06233b663f76cfce66ce0b65498c9a3200a399e2a26d3fe89efdd3da69a50e9d94d971ecf4b8868048a7fb8af40ec64d51231eca4018a7cf 0002-various-header-include-fixes-for-building-with-musl-.patch
-d70ebb4ff90a39d91d2ddc04f94c96a50c202c8a4c1c7bc6e84c5c507c580b6973a31337a81ad149068d58017135ed906106cc5fafff0edc883c565f0afc61d8 0003-unit-prevent-use-of-glibc-s-error-3.patch
+sha512sums="27ac9aa98107b234696885ce3f40736dc25b9e4b34baa6b4d9dd3f0b81d4ca364a819f42801bddc8c1a247be1db37ac3c7e7802188ad943b996c07b640db65b1 bluez-5.16.tar.xz
+b7c946cac036a639eeb31e34437ed8e84b6613bc8da7b564b585b30bd02323843545b932ee49c2f53176315075f57e471ba397a725e052f7a3bfdc68c2e4ec32 0001-shared-include-endian.h-for-be32toh-htobe32-and-htob.patch
+e1cd0675c037ab1cfdbda0cbb8e1ea493ee1ad9fb447c4836b9fd97df35ee63a6535f903ea6260c3fa40a36b48fdc8bff490a98f659edb8717adb3bc854d6c0e 0002-unit-prevent-unintended-use-of-glibc-s-error-3.patch
+90b8270e3101f1e8e2bbde1f31b27cedaac40ebbd91e754ce5150829667cfb15b9ba71bd39bfb6fff6d4d72a905b1cdf0eba84931adecc1236902bfe37b9020e 0003-bnep-avoid-use-of-caddr_t.patch
2c13cde6561c5aa8b2f27306851458966c67853f6ac2358d09019fda14d3d8e3ff6d9f1c90512c67063d1e1954ec05bf117c5fafc7716446cc5786e9cc12c49f bluetooth.initd
8f14b4e05c9ecaf4586ed2fdc2d2519de6b613de62ae5c95508baa682630f3112c5b6db6850f76679afc49e06f2ad035d148fa30b9b980747b6fb423f7bebe88 rfcomm.initd
a70aa0dbbabe7e29ee81540a6f98bf191a850da55a28f678975635caf34b363cf4d461a801b3484120ee28fdd21240bd456a4f5d706262700924bd2e9a0972fb rfcomm.confd"