summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2013-10-20 12:45:05 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-10-20 12:45:47 +0200
commitd50a574f3f773ff759ccbbcac7f45d9b41d1f592 (patch)
tree5893cb2df8f154aaf25b2b1502bb735f6b582f1b /main
parentdab0650b1be6f82e4bfa45c9764d2a3a162b36f8 (diff)
downloadaports-d50a574f3f773ff759ccbbcac7f45d9b41d1f592.tar.bz2
aports-d50a574f3f773ff759ccbbcac7f45d9b41d1f592.tar.xz
main/imagemagick: disable PIC for x86
Diffstat (limited to 'main')
-rw-r--r--main/imagemagick/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/main/imagemagick/APKBUILD b/main/imagemagick/APKBUILD
index 4fa49b79c..07e122f52 100644
--- a/main/imagemagick/APKBUILD
+++ b/main/imagemagick/APKBUILD
@@ -26,6 +26,9 @@ prepare() {
}
build() {
+ local _pic=""
+ [ "$CARCH" = "x86" ] && _pic="--disable-pic"
+
cd "$srcdir/ImageMagick-${_pkgver}"
# fix doc dir, Gentoo bug 91911
@@ -45,6 +48,7 @@ build() {
--with-gslib \
--with-gs-font-dir=/usr/share/fonts/Type1 \
--with-modules \
+ $_pic
|| return 1
make || return 1
}