summaryrefslogtreecommitdiffstats
path: root/testing/perl-scope-guard
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-31 13:42:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-31 13:42:04 +0000
commit81177b020ba115ffeeaf6c4c0ba21fb3808b9df9 (patch)
tree0582db8d15908583a74545e18097e3d38c135e3c /testing/perl-scope-guard
parent78b366c4802aeb67b3ec53621598c23d3f5a3804 (diff)
downloadaports-81177b020ba115ffeeaf6c4c0ba21fb3808b9df9.tar.bz2
aports-81177b020ba115ffeeaf6c4c0ba21fb3808b9df9.tar.xz
testing/perl-scope-guard: new aport
Scope::Guard perl module http://search.cpan.org/dist/Scope-Guard/
Diffstat (limited to 'testing/perl-scope-guard')
-rw-r--r--testing/perl-scope-guard/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/perl-scope-guard/APKBUILD b/testing/perl-scope-guard/APKBUILD
new file mode 100644
index 000000000..bd4706430
--- /dev/null
+++ b/testing/perl-scope-guard/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-scope-guard
+pkgver=0.20
+pkgrel=0
+pkgdesc="Scope::Guard perl module"
+url="http://search.cpan.org/dist/Scope-Guard/"
+arch="noarch"
+license="GPLv2 or Artistic"
+depends="perl"
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/C/CH/CHOCOLATE/Scope-Guard-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Scope-Guard-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make && make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="495d5ae16a2df8128fd068c386c9d4ac Scope-Guard-0.20.tar.gz"