summaryrefslogtreecommitdiffstats
path: root/testing/py-ansi2html
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-28 15:37:31 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-09-29 14:07:42 +0000
commit8e67000f41e2f4102e5b290b97231e0f64c90971 (patch)
treeebb8763d1873b9650fcc704895d18a80df0c953f /testing/py-ansi2html
parentfcda338663aedd205671721597860bdddbb6b26e (diff)
downloadaports-8e67000f41e2f4102e5b290b97231e0f64c90971.tar.bz2
aports-8e67000f41e2f4102e5b290b97231e0f64c90971.tar.xz
testing/py-ansi2html: new aport
Convert text with ANSI color codes to HTML http://github.com/ralphbean/ansi2html/
Diffstat (limited to 'testing/py-ansi2html')
-rw-r--r--testing/py-ansi2html/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-ansi2html/APKBUILD b/testing/py-ansi2html/APKBUILD
new file mode 100644
index 000000000..26548758f
--- /dev/null
+++ b/testing/py-ansi2html/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-ansi2html
+_pkgname=ansi2html
+pkgver=0.10.0
+pkgrel=0
+pkgdesc="Convert text with ANSI color codes to HTML"
+url="http://github.com/ralphbean/ansi2html/"
+arch="noarch"
+license="GPL3+"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="e68cb6e4f949a3bfcc476e7aa4ed3b52 ansi2html-0.10.0.tar.gz"
+sha256sums="597c972706e60b8ba757d282d5f92ac40b369d26211410d9178f89423c9da9c2 ansi2html-0.10.0.tar.gz"
+sha512sums="24c604309ae258e1e3caf09ca563d2b431c3188c1161badffe245ed18fd7f4522c377d173e0e426ee50128be2201d682517607d9c32c30e36208eddbec89f16e ansi2html-0.10.0.tar.gz"