summaryrefslogtreecommitdiffstats
path: root/testing/py-bumpy
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-07 07:53:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:16 +0000
commitde8f518e4d99fe473239e5ec76699b7b3b77228c (patch)
treea190f92c67021e899e588e627d4324f870c5b453 /testing/py-bumpy
parentf996820f77ea24f67f702ba66c585368e83d58af (diff)
downloadaports-de8f518e4d99fe473239e5ec76699b7b3b77228c.tar.bz2
aports-de8f518e4d99fe473239e5ec76699b7b3b77228c.tar.xz
testing/py-bumpy: new aport
A Python file builder and CLI tool http://github.com/scizzorz/bumpy
Diffstat (limited to 'testing/py-bumpy')
-rw-r--r--testing/py-bumpy/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-bumpy/APKBUILD b/testing/py-bumpy/APKBUILD
new file mode 100644
index 000000000..08ee91e72
--- /dev/null
+++ b/testing/py-bumpy/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bumpy
+_pkgname=bumpy
+pkgver=0.4.2
+pkgrel=0
+pkgdesc="A Python file builder and CLI tool"
+url="http://github.com/scizzorz/bumpy"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="4c81ec8dd065d8f9929f87b1d0c31412 bumpy-0.4.2.tar.gz"
+sha256sums="36e387dea826c8469d57832deafa0c8829a82d8c857b721eaddacd8c0eb5335b bumpy-0.4.2.tar.gz"
+sha512sums="05ca73d0f2fde7a2d6e6193521d3c0e463fa0bc15e70c966557a6904ec2556e357ccd7000ee8128fe3139da35b446eae5043a620eeaefd23abc5246be68875c7 bumpy-0.4.2.tar.gz"