summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-03-03 16:57:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-03-11 07:33:00 +0000
commit0201a751b11887173b48c551683d77c85057100a (patch)
treed501e086d89851da2b081c178b7d01c565e39831 /testing
parent2c68b1c9f833b1a42520e3cfd6c3b90c4359c982 (diff)
downloadaports-0201a751b11887173b48c551683d77c85057100a.tar.bz2
aports-0201a751b11887173b48c551683d77c85057100a.tar.xz
testing/py-netlib: new aport
A Collection of network utility classes https://github.com/mitmproxy/netlib
Diffstat (limited to 'testing')
-rw-r--r--testing/py-netlib/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-netlib/APKBUILD b/testing/py-netlib/APKBUILD
new file mode 100644
index 000000000..01ae9d88b
--- /dev/null
+++ b/testing/py-netlib/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-netlib
+_pkgname=netlib
+pkgver=0.10
+pkgrel=0
+pkgdesc="A Collection of network utility classes"
+url="https://github.com/mitmproxy/netlib"
+arch="noarch"
+license="MIT"
+depends="python py-openssl py-asn1"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="88e56d7bcf2c40cf0ba4b341ac09af0f netlib-0.10.tar.gz"
+sha256sums="415e3db96f487177f372d47bc669dcc9068a435e49b8120ec8821026de36bd80 netlib-0.10.tar.gz"
+sha512sums="e6897a1ba28942eb30f19b4876bf1fcc03a83ec619e162ee09d9c3ad3348cfaebf9b413fdc4c534c56342270c0c767f16b63b79efe51d6589e864e9b51742f4a netlib-0.10.tar.gz"