summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-18 18:40:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-18 18:46:50 +0000
commit20810d39856c166f28ca1ee172374e30b85499b0 (patch)
treef9aa1391ab09f82223638dfab1a429f7e3bdf7de /testing
parent823571c4baa75832a6143eff88e0ab14be30a3ad (diff)
downloadaports-20810d39856c166f28ca1ee172374e30b85499b0.tar.bz2
aports-20810d39856c166f28ca1ee172374e30b85499b0.tar.xz
testing/shorewall: upgrade top 4.5.21
Diffstat (limited to 'testing')
-rw-r--r--testing/shorewall/APKBUILD16
-rw-r--r--testing/shorewall/shorewall.initd51
2 files changed, 24 insertions, 43 deletions
diff --git a/testing/shorewall/APKBUILD b/testing/shorewall/APKBUILD
index e29cfa1d8..e825ab2e7 100644
--- a/testing/shorewall/APKBUILD
+++ b/testing/shorewall/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall
-pkgver=4.5.20
+pkgver=4.5.21
pkgrel=0
-pkgdesc="Core libraries for Shorewall"
+pkgdesc="An iptables front end for firewall configuration"
url="http://www.shorewall.net/"
arch="noarch"
license="GPL-2"
@@ -38,9 +38,9 @@ package() {
install -m755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
}
-md5sums="d13bb8d730b3f3697895674c123dc4e5 shorewall-4.5.20.tar.bz2
-a59c0ec3f299f6a383d33aacbdc83e44 shorewall.initd"
-sha256sums="645336e86ba08e14a5565209b461855fbc9034f3718f7bb39db92f835e6f6aac shorewall-4.5.20.tar.bz2
-ee8cff251a24cc5f9b31e835682f6fc7d9f01625e93c2f9d8c82c859dad09e8e shorewall.initd"
-sha512sums="320cb1757a4f50726d68b2925edb63c4c37b5ab48dbd798f9447a8cd7d6634e55479f1942c25a60c8791432bf67231d2a27b51c62d969557e6a06c6367381016 shorewall-4.5.20.tar.bz2
-365819451ee3a412c321eea4d3011c548295f00f9dd2cbb996c84a61be77eae859d568077677f1acad64af2a642028e2ef577a3757239703153b3293232afade shorewall.initd"
+md5sums="41773c809975b6bfbc652d674c7f26cb shorewall-4.5.21.tar.bz2
+ac29ec1138be791eeed8437d1573c5c3 shorewall.initd"
+sha256sums="76bf9e24ec2ae3fb7ffe4f536861ca7f85fc9f2bb57fba2f0a553102e7085bcb shorewall-4.5.21.tar.bz2
+917469b5283d3a8b98628436d1ab789d05c91a0ae8b51c302e3d3a2287432770 shorewall.initd"
+sha512sums="64945c02f964ff93006883a2d65c3800381191e2f2b00611abef68549397abd2a28310b6daab1f5ae36da0c1c2b661d2e778abb08906ec72f24b802faf44d329 shorewall-4.5.21.tar.bz2
+603aaed777930e4a37bc45e2cb5893b7d1919ead02658cfba1a6f09f57661c1de0e4dadcf0f51d59bb95feaffc335c4ec66eb3d61576139962fad49eefc3452b shorewall.initd"
diff --git a/testing/shorewall/shorewall.initd b/testing/shorewall/shorewall.initd
index 6dadd3064..5f5397115 100644
--- a/testing/shorewall/shorewall.initd
+++ b/testing/shorewall/shorewall.initd
@@ -3,14 +3,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/files/shorewall.initd,v 1.4 2013/07/13 14:09:09 constanze Exp $
+command=/sbin/shorewall
extra_commands="check clear"
-extra_started_commands="refresh reset"
-
-checkconfig() {
- if [ ! -d /var/lock/subsys ] ; then
- checkpath -d -m 755 /var/lock/subsys
- fi
-}
+extra_started_commands="refresh reset safe_restart"
depend() {
need net
@@ -19,35 +14,21 @@ depend() {
}
start() {
- checkconfig
+ checkpath -d -m 755 /var/lock/subsys
ebegin "Starting shorewall"
- /sbin/shorewall -f start 1>/dev/null
- eend $?
+ $command -f start 1>/dev/null
+ eend $?
}
stop() {
ebegin "Stopping shorewall"
- /sbin/shorewall stop 1>/dev/null
+ $command stop 1>/dev/null
eend $?
}
-restart() {
- checkconfig
- # shorewall comes with its own control script that includes a
- # restart function, so refrain from calling svc_stop/svc_start
- # here. Note that this comment is required to fix bug 55576;
- # runscript.sh greps this script... (09 Jul 2004 agriffis)
- ebegin "Restarting shorewall"
- /sbin/shorewall status >/dev/null
- if [ $? != 0 ] ; then
- svc_start
- else
- if [ -f /var/lib/shorewall/restore ] ; then
- /sbin/shorewall restore
- else
- /sbin/shorewall restart 1>/dev/null
- fi
- fi
+safe_restart() {
+ ebegin "Safely restarting shorewall"
+ $command safe-restart 1>/dev/null
eend $?
}
@@ -56,7 +37,7 @@ clear() {
# state. (21 Nov 2004 eldad)
ebegin "Clearing all shorewall rules and setting policy to ACCEPT"
- /sbin/shorewall clear
+ $command clear
eend $?
}
@@ -64,26 +45,26 @@ reset() {
# reset the packet and byte counters in the firewall
ebegin "Resetting the packet and byte counters in the shorewall"
- /sbin/shorewall reset
+ $command reset
eend $?
}
refresh() {
- # refresh the rules involving the broadcast addresses of firewall
- # interfaces, the black list, traffic control rules and
+ # refresh the rules involving the broadcast addresses of firewall
+ # interfaces, the black list, traffic control rules and
# ECN control rules
ebegin "Refreshing shorewall rules"
- /sbin/shorewall refresh
+ $command refresh
eend $?
}
check() {
# perform cursory validation of the zones, interfaces, hosts, rules
- # and policy files. CAUTION: does not parse and validate the generated
+ # and policy files. CAUTION: does not parse and validate the generated
# iptables commands.
ebegin "Checking configuration files"
- /sbin/shorewall check
+ $command check
eend $?
}