summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2013-10-20 13:48:57 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-10-20 13:59:43 +0200
commit40202b7c1e1fb1ca1d90cc42369c130cebe047f3 (patch)
tree0d914991f6f4aed8f657c7c1c2450bd6b44bbe46 /testing
parent440dc05ed414d3c8a412c10d4d132c4fe4c13a73 (diff)
downloadaports-40202b7c1e1fb1ca1d90cc42369c130cebe047f3.tar.bz2
aports-40202b7c1e1fb1ca1d90cc42369c130cebe047f3.tar.xz
testing/pcmanfm: new aport
Pcmanfm is a lightweight file manager.
Diffstat (limited to 'testing')
-rw-r--r--testing/pcmanfm/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/pcmanfm/APKBUILD b/testing/pcmanfm/APKBUILD
new file mode 100644
index 000000000..efb32f0d1
--- /dev/null
+++ b/testing/pcmanfm/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=pcmanfm
+pkgver=1.1.2
+pkgrel=0
+pkgdesc='Extremely fast and lightweight file manager'
+arch='all'
+url='http://pcmanfm.sourceforge.net/'
+license='GPL'
+makedepends='gtk+2.0-dev libfm-dev intltool'
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --sysconfdir=/etc --prefix=/usr || return 1
+ make LDFLAGS+=' -lm' || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install || return 1
+
+ sed -i 's|x-directory/normal|inode/directory|' \
+ "$pkgdir"/usr/share/applications/pcmanfm.desktop || return 1
+}
+
+md5sums="41104699e653ff2b0a9a9e80a257d6a2 pcmanfm-1.1.2.tar.gz"
+sha256sums="23ee33b34066ac83ce9a98bc9930049e69839438fb60489bd453bec8c2068950 pcmanfm-1.1.2.tar.gz"
+sha512sums="0640919477bef8a88b76eb96aaf7f261c423189b60b27f720514040b4006ab5d9d30db5f25380320efc322ca2631298c72ee52a92bebf11ebf162eaa577058e1 pcmanfm-1.1.2.tar.gz"