summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-03-06 08:31:55 +0100
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-03-06 08:32:27 +0100
commit43013cbe3ab50707ce184d7fea90034da61b0d15 (patch)
tree87867553dcead3c5f03000976bd15c6f7d5357b0 /testing
parent4db272e0366f840ae2b9c025fb0d71e561c83b21 (diff)
downloadaports-43013cbe3ab50707ce184d7fea90034da61b0d15.tar.bz2
aports-43013cbe3ab50707ce184d7fea90034da61b0d15.tar.xz
testing/rpm: fix uclibc build
Diffstat (limited to 'testing')
-rw-r--r--testing/rpm/APKBUILD8
-rw-r--r--testing/rpm/rpm-uclibc.patch2
2 files changed, 5 insertions, 5 deletions
diff --git a/testing/rpm/APKBUILD b/testing/rpm/APKBUILD
index 51fbae74b..af66714bf 100644
--- a/testing/rpm/APKBUILD
+++ b/testing/rpm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=rpm
pkgver=4.11.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="The RPM package manager"
url="http://www.rpm.org/"
arch="all"
@@ -59,8 +59,8 @@ py_rpm() {
}
md5sums="b35f5359e0d4494d7b11e8d0c1512a0d rpm-4.11.0.1.tar.bz2
-e20eb0419329aa42eabe4595ce7f4756 rpm-uclibc.patch"
+528cdfc96ebfe8db3e389abdcf024d94 rpm-uclibc.patch"
sha256sums="98496c0c73095d7c66a8b6f1d8ab00998e1daf4e46a017ae74190c65132ffb21 rpm-4.11.0.1.tar.bz2
-beefbc9a4b94f78e667c1d1932d2c726028583a374ec984db7aa4eb448143c2c rpm-uclibc.patch"
+e963102ba11f83b691ad27ca7df9283524710a8fbd458e85e6ac84f3413778e9 rpm-uclibc.patch"
sha512sums="72bd3054b2d0def1e25fba7113eda14def38baef62b558e65cafaf3b374823d0905d982772cffddfd9dc6698eff293251acb2ace7dfda0964085669caa88d535 rpm-4.11.0.1.tar.bz2
-601e6094f0fbf33c7435637d56814c829edbe9ce255052084cd40fc8bb6c05dd06faf72a880090c6930c71f3885b3d35f621f45898dd8492d9df3dc2b35dd0a6 rpm-uclibc.patch"
+7a5796716b0f53e0c7fde5d7f42bd767eb2dd03fda03179779b7085e7f0dfc72a1c246621458d3bbe6227a5d59074b3f29147eea34d889a700b3ff47b799c2ce rpm-uclibc.patch"
diff --git a/testing/rpm/rpm-uclibc.patch b/testing/rpm/rpm-uclibc.patch
index 03cfbacf1..12636f0fc 100644
--- a/testing/rpm/rpm-uclibc.patch
+++ b/testing/rpm/rpm-uclibc.patch
@@ -22,7 +22,7 @@ diff -rupN a/misc/fts.c b/misc/fts.c
-#include <string.h>
-#include <errno.h>
-#include "misc/fts.h"
-+#ifndef __GLIBC__
++#if !defined(__GLIBC__) || defined(__UCLIBC__)
+# define _STAT_VER 0
+# define __fxstat64(_stat_ver, _fd, _sbp) fstat64((_fd), (_sbp))
+#endif