summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2013-12-03 11:54:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-12-03 16:00:56 +0000
commit8941d8b2c32e6b3c2554d25657f308cea69ad207 (patch)
tree495c0989b5b14e5f6dbcc139788c4af8b47d785a /testing
parent6fefc97fa58a5c9dd34a2c8e17e108f2fc2b0dc8 (diff)
downloadaports-8941d8b2c32e6b3c2554d25657f308cea69ad207.tar.bz2
aports-8941d8b2c32e6b3c2554d25657f308cea69ad207.tar.xz
testing/ghi: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/ghi/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/ghi/APKBUILD b/testing/ghi/APKBUILD
new file mode 100644
index 000000000..2412dfb27
--- /dev/null
+++ b/testing/ghi/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Eivind Uggedal <eivind@uggedal.com>
+pkgname=ghi
+pkgver=0.9.0.20131120
+pkgrel=0
+pkgdesc="GitHub Issues on the command line"
+url="https://github.com/stephencelis/ghi"
+arch="noarch"
+license="MIT"
+depends="ruby"
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/stephencelis/ghi/archive/$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$_builddir"
+
+ sed -n '/(<stephen@stephencelis.com>).$/,$p' README.markdown > LICENSE
+}
+
+package() {
+ cd "$_builddir"
+
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -D -m644 man/$pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+md5sums="08f154b4eccf5fbf5ed8f3d13d937af9 ghi-0.9.0.20131120.tar.gz"
+sha256sums="b2971718f0a7d5187aa96ac9954bdec9055ecef7df36ca9ef01ce008d4d66368 ghi-0.9.0.20131120.tar.gz"
+sha512sums="57dcafd4de34a27a55bc9ac0512c5304c6ea548a2a640d5cc0bf3141802ca2279ee0fc677a0587e76194632ed69657654944e52de7c9b344852e0c73e7e1530a ghi-0.9.0.20131120.tar.gz"