summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-03-05 11:39:09 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-03-05 11:39:09 +0000
commita5ac58262ab0318bc181c18c069d65325460d58b (patch)
tree34553778009afa4439b41fee2b1c1bfcde9c6398 /testing
parent2c964e6a6acf11009697728606a131380b20bbc2 (diff)
downloadaports-a5ac58262ab0318bc181c18c069d65325460d58b.tar.bz2
aports-a5ac58262ab0318bc181c18c069d65325460d58b.tar.xz
testing/omxplayer: upgrade to snapshot of 2014-03-02
fix also the default font
Diffstat (limited to 'testing')
-rw-r--r--testing/omxplayer/APKBUILD22
-rw-r--r--testing/omxplayer/default-font.patch24
-rw-r--r--testing/omxplayer/fix-makefile.patch3
3 files changed, 39 insertions, 10 deletions
diff --git a/testing/omxplayer/APKBUILD b/testing/omxplayer/APKBUILD
index 1ec1427cd..4584bbc5e 100644
--- a/testing/omxplayer/APKBUILD
+++ b/testing/omxplayer/APKBUILD
@@ -1,18 +1,19 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=omxplayer
-pkgver=0.20140220
-_commitid=7af21f596378e5efeceebedff9c4a298e2d06d98
+pkgver=0.20140302
+_commitid=16d8b48aff320be42cb792165bc4a444b69f05a7
pkgrel=0
pkgdesc="Commandline OMX player for Raspberry Pi"
url="https://github.com/popcornmix/omxplayer"
arch="armhf"
license="GPLv2"
-depends=""
+depends="ttf-dejavu"
makedepends="raspberrypi-dev ffmpeg-dev pcre-dev boost-dev freetype-dev dbus-dev"
install=""
subpackages="$pkgname-doc"
source="omxplayer-$pkgver.tar.gz::https://github.com/popcornmix/omxplayer/archive/$_commitid.tar.gz
fix-makefile.patch
+ default-font.patch
"
_srcdir="$srcdir"/$pkgname-$_commitid
@@ -45,9 +46,12 @@ package() {
rm -rf "$pkgdir"/usr/lib/omxplayer
}
-md5sums="2e6617526222462a381ea2d2e51b71cb omxplayer-0.20140220.tar.gz
-d2e426af74fc1ccad6f01159c29e46f4 fix-makefile.patch"
-sha256sums="02c597538f9c0b7a2372e593e409684b50cceda72fa2f6cae93378acf28a6a78 omxplayer-0.20140220.tar.gz
-f7b62b3ac32f0f37710d347ad2a73f3588161d5e2469487bee9fa3c88b444dd9 fix-makefile.patch"
-sha512sums="3aae6a6184ce9418cfae82c831f9be8a2529b672ed8597fc12383cb84cffe68de4a5ec489bcc2321a2872e238e610d64a8321f69b795afb921e5dca711cc138e omxplayer-0.20140220.tar.gz
-4efde13e52b129ca04833d50e1195ff9d2901a5de920ca7c2ebeb156db7383ea6fac66f49e450858528eedda63a853d5464fed055b57a3eea906cf6e7c840e55 fix-makefile.patch"
+md5sums="3f4d07681e3d066ab853fe3a1586aebe omxplayer-0.20140302.tar.gz
+a105ca8848de5d302832b5ceba037681 fix-makefile.patch
+b5bdfa2b2f86770bc33e46620b6e0c67 default-font.patch"
+sha256sums="e1d47c4da56cbb9c47e296f93b1c3a759fc9e4bca8fd5b8fb86d76c3be59699e omxplayer-0.20140302.tar.gz
+df53982e679d43f8a344575ad6008e2beba3135265c12c1c8728303822d76863 fix-makefile.patch
+e25f1053f59bc3eeae246cc8d229044e6924acfddbff3252b9b3635c7bed74bb default-font.patch"
+sha512sums="bee0d10ad7e5215f04ac542519e4cadbaca9552171a803f43349f9811a8589c97bc7943b03e606a4810fb2f9e5e3294544f98b8266e37fd7035c2f2e60db22af omxplayer-0.20140302.tar.gz
+f9b83c3981261eea9a257c6bab596b105d62f3fa94f20c4a0567f8f32931b4fa7bbbf9d2ca8716aaeb4a2b34bbbe44e013c1cf22e916c8d35355f247e67fcc48 fix-makefile.patch
+bdea38f5c7df35bab9a788a060de8151e63c1fcba314fd6f48e2fad3c3af1484553f1aad61790412212a7fa49bfd442f0542e830a2e022f7699605929ef75c23 default-font.patch"
diff --git a/testing/omxplayer/default-font.patch b/testing/omxplayer/default-font.patch
new file mode 100644
index 000000000..2141bd448
--- /dev/null
+++ b/testing/omxplayer/default-font.patch
@@ -0,0 +1,24 @@
+--- omxplayer-7af21f596378e5efeceebedff9c4a298e2d06d98.orig/omxplayer.cpp
++++ omxplayer-7af21f596378e5efeceebedff9c4a298e2d06d98/omxplayer.cpp
+@@ -88,8 +88,8 @@
+ bool m_osd = true;
+ std::string m_external_subtitles_path;
+ bool m_has_external_subtitles = false;
+-std::string m_font_path = "/usr/share/fonts/truetype/freefont/FreeSans.ttf";
+-std::string m_italic_font_path = "/usr/share/fonts/truetype/freefont/FreeSansOblique.ttf";
++std::string m_font_path = "/usr/share/fonts/TTF/DejaVuSans.ttf";
++std::string m_italic_font_path = "/usr/share/fonts/TTF/DejaVuSans-Oblique.ttf";
+ std::string m_dbus_name = "org.mpris.MediaPlayer2.omxplayer";
+ bool m_asked_for_font = false;
+ bool m_asked_for_italic_font = false;
+@@ -170,8 +170,8 @@
+ printf(" --no-osd do not display status information on screen\n");
+ printf(" --subtitles path external subtitles in UTF-8 srt format\n");
+ printf(" --font path subtitle font\n");
+- printf(" (default: /usr/share/fonts/truetype/freefont/FreeSans.ttf)\n");
+- printf(" --italic-font path (default: /usr/share/fonts/truetype/freefont/FreeSansOblique.ttf)\n");
++ printf(" (default: /usr/share/fonts/TTF/DejaVuSans.ttf)\n");
++ printf(" --italic-font path (default: /usr/share/fonts/TTF/DejaVuSans-Oblique.ttf)\n");
+ printf(" --font-size size font size as thousandths of screen height\n");
+ printf(" (default: 55)\n");
+ printf(" --align left/center subtitle alignment (default: left)\n");
diff --git a/testing/omxplayer/fix-makefile.patch b/testing/omxplayer/fix-makefile.patch
index 1dd8f6dfb..cc9f46678 100644
--- a/testing/omxplayer/fix-makefile.patch
+++ b/testing/omxplayer/fix-makefile.patch
@@ -18,7 +18,8 @@
+install: omxplayer.bin
mkdir -p $(DIST)/usr/bin
mkdir -p $(DIST)/usr/share/doc
- cp omxplayer omxplayer.bin $(DIST)/usr/bin
+- cp omxplayer omxplayer.bin $(DIST)/usr/bin
++ cp omxplayer.bin $(DIST)/usr/bin/omxplayer
cp COPYING $(DIST)/usr/share/doc/
cp README.md $(DIST)/usr/share/doc/README
- cp -a ffmpeg_compiled/usr/local/lib/*.so* $(DIST)/usr/lib/omxplayer/