summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-12-04 07:36:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-12-04 07:36:42 +0000
commited71a3ec7a9070acb6d19ed239d04a51a5ab501f (patch)
tree7016da0fab02d6922c05715f2e118a380e59ffd3 /testing
parent37c51981399afc62cbfbab91c91405089eb0454d (diff)
downloadaports-ed71a3ec7a9070acb6d19ed239d04a51a5ab501f.tar.bz2
aports-ed71a3ec7a9070acb6d19ed239d04a51a5ab501f.tar.xz
testing/qt5-base: fix for xcb 1.9.3
Diffstat (limited to 'testing')
-rw-r--r--testing/qt5-qtbase/APKBUILD10
-rw-r--r--testing/qt5-qtbase/xcb-193.patch13
2 files changed, 20 insertions, 3 deletions
diff --git a/testing/qt5-qtbase/APKBUILD b/testing/qt5-qtbase/APKBUILD
index 713f90c98..2d7ee861c 100644
--- a/testing/qt5-qtbase/APKBUILD
+++ b/testing/qt5-qtbase/APKBUILD
@@ -42,6 +42,7 @@ subpackages="$pkgname-dev $pkgname-doc
$pkgname-sqlite $pkgname-odbc $pkgname-postgresql $pkgname-mysql
$pkgname-tds $pkgname-x11"
source="http://download.qt-project.org/official_releases/qt/${pkgver%.*}/$pkgver/submodules/qtbase-opensource-src-$pkgver.tar.xz
+ xcb-193.patch
"
_builddir="$srcdir"/qtbase-opensource-src-$pkgver
prepare() {
@@ -176,6 +177,9 @@ x11() {
return 0
}
-md5sums="955d1e4da875f3872ef3208f21a757dd qtbase-opensource-src-5.1.1.tar.xz"
-sha256sums="d4620e0b1aff6d2b6f4d8066e6f8258e012a8b5507af7c03b661029a1ffa75c9 qtbase-opensource-src-5.1.1.tar.xz"
-sha512sums="db7e25a520584b10370d898747f2cfb84ebbce3a8b9027f373cac7ab713fe199da5465df2453d04107406101ad4eff8cd82871efab40377ff44d789a424667c3 qtbase-opensource-src-5.1.1.tar.xz"
+md5sums="955d1e4da875f3872ef3208f21a757dd qtbase-opensource-src-5.1.1.tar.xz
+92d65cbeb660f0785ca882f7a4efb949 xcb-193.patch"
+sha256sums="d4620e0b1aff6d2b6f4d8066e6f8258e012a8b5507af7c03b661029a1ffa75c9 qtbase-opensource-src-5.1.1.tar.xz
+5cf353c03ffadc49b9def3149bccdc783b984a4a9ba37b8d77d3626093678bdb xcb-193.patch"
+sha512sums="db7e25a520584b10370d898747f2cfb84ebbce3a8b9027f373cac7ab713fe199da5465df2453d04107406101ad4eff8cd82871efab40377ff44d789a424667c3 qtbase-opensource-src-5.1.1.tar.xz
+99fb569bc01622380dc8517b3eb1b4a4c90b396f9262f17bb79b9e33046d4c928914bb709accd0b6f303a7dbc5f00ec3e7b2726f847a91beae4ed5f9668f0985 xcb-193.patch"
diff --git a/testing/qt5-qtbase/xcb-193.patch b/testing/qt5-qtbase/xcb-193.patch
new file mode 100644
index 000000000..5ad3623cb
--- /dev/null
+++ b/testing/qt5-qtbase/xcb-193.patch
@@ -0,0 +1,13 @@
+diff --git a/src/plugins/platforms/xcb/qxcbconnection.cpp b/src/plugins/platforms/xcb/qxcbconnection.cpp
+index cc8c42f..d03ea6f 100644
+--- a/src/plugins/platforms/xcb/qxcbconnection.cpp
++++ b/src/plugins/platforms/xcb/qxcbconnection.cpp
+@@ -1752,7 +1752,7 @@ bool QXcbConnection::xi2GetValuatorValueIfSet(void *event, int valuatorNum, doub
+ bool QXcbConnection::xi2PrepareXIGenericDeviceEvent(xcb_ge_event_t *event, int opCode)
+ {
+ // xGenericEvent has "extension" on the second byte, xcb_ge_event_t has "pad0".
+- if (event->pad0 == opCode) {
++ if (event->extension == opCode) {
+ // xcb event structs contain stuff that wasn't on the wire, the full_sequence field
+ // adds an extra 4 bytes and generic events cookie data is on the wire right after the standard 32 bytes.
+ // Move this data back to have the same layout in memory as it was on the wire