summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-01-23 16:27:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-03-03 13:03:42 +0000
commitf796f072b4f1b4b1355cff6d77cc221725c01e42 (patch)
treebf3dca85c5f0100137a19868b17abaf8095f83c8 /testing
parentb6eb25efd91d00dfa15982cb13aa8d896e5b0fc0 (diff)
downloadaports-f796f072b4f1b4b1355cff6d77cc221725c01e42.tar.bz2
aports-f796f072b4f1b4b1355cff6d77cc221725c01e42.tar.xz
testing/py-frosted: new aport
A passive Python syntax checker https://github.com/timothycrosley/frosted
Diffstat (limited to 'testing')
-rw-r--r--testing/py-frosted/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-frosted/APKBUILD b/testing/py-frosted/APKBUILD
new file mode 100644
index 000000000..681110fe7
--- /dev/null
+++ b/testing/py-frosted/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-frosted
+_pkgname=frosted
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="A passive Python syntax checker"
+url="https://github.com/timothycrosley/frosted"
+arch="noarch"
+license="MIT"
+depends="python py-pies"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="65e2d54bfb211b9ab01ccefae2d88b46 frosted-1.2.0.tar.gz"
+sha256sums="73f02ee2f95282fb62b2289060e1a0705de276df8ee11f7824da0f66f83037cc frosted-1.2.0.tar.gz"
+sha512sums="6b3921677638df42e9c78a9874525f0f21d35220b3f532141b944a554b35afa427b43f6c1b93276ac71574e43f231f3b1745a4be8000cbaaad6a17f433910a00 frosted-1.2.0.tar.gz"