summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-01-23 13:58:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-03-03 13:03:41 +0000
commitfe49b768ac8514ac09e6c51488e7be5995da7faf (patch)
tree15b1e61ebcb9ff57f3d2794e29689207a6b17750 /testing
parent6fe827c035df81e86d18e2af1f5bf31dffe9dea5 (diff)
downloadaports-fe49b768ac8514ac09e6c51488e7be5995da7faf.tar.bz2
aports-fe49b768ac8514ac09e6c51488e7be5995da7faf.tar.xz
testing/pysysbot: new aport
This python jabber (XMPP) bot is based on the jabberbot framework. The bot is capable to display details about the system it is running on. http://affolter-engineering.ch/pysysbot/
Diffstat (limited to 'testing')
-rw-r--r--testing/pysysbot/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/pysysbot/APKBUILD b/testing/pysysbot/APKBUILD
new file mode 100644
index 000000000..173a7f9c1
--- /dev/null
+++ b/testing/pysysbot/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=pysysbot
+pkgver=0.1.3
+pkgrel=0
+pkgdesc="A Python based system jabber bot"
+url="http://affolter-engineering.ch/pysysbot/"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-psutil py-jabberbot"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="79a52a23cd8cfbb0333a8ed54f094482 pysysbot-0.1.3.tar.gz"
+sha256sums="565f3475dc52968aefdd54605c122dcd3e35a5739894fa1181418f923b947a43 pysysbot-0.1.3.tar.gz"
+sha512sums="ae6ecd1775747be578874603fcd7305ad0d6599858d1f9beb069a2fb874bba33483f9aefa9f6a090714469fbb29ab327c76b8f77c35f05ebef9618a44befea6e pysysbot-0.1.3.tar.gz"