summaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-02-08 16:06:54 +0100
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2014-02-08 16:06:54 +0100
commit32a6e9f51d5f30bcf7ef8d4cd749432141e12414 (patch)
tree6d069a35fee6ad870d999eaaf9eb54d2f88e7744 /unmaintained
parent18c0c7d2102de745ee647eb8306193f2e44d00a8 (diff)
downloadaports-32a6e9f51d5f30bcf7ef8d4cd749432141e12414.tar.bz2
aports-32a6e9f51d5f30bcf7ef8d4cd749432141e12414.tar.xz
testing/kdesdk: move to unmaintained
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/kdesdk/APKBUILD42
-rw-r--r--unmaintained/kdesdk/not-glibc.patch12
2 files changed, 54 insertions, 0 deletions
diff --git a/unmaintained/kdesdk/APKBUILD b/unmaintained/kdesdk/APKBUILD
new file mode 100644
index 000000000..b97385236
--- /dev/null
+++ b/unmaintained/kdesdk/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=kdesdk
+pkgver=4.6.3
+pkgrel=1
+pkgdesc="software development tools for kde"
+url="http://www.kde.org/"
+#arch="all"
+license="GPL"
+depends=
+depends_dev="kdebase-workspace-dev hunspell-dev boost-dev perl-dev subversion-dev"
+makedepends="$depends_dev cmake automoc4"
+install=""
+subpackages="$pkgname-dev"
+source="http://kde.mirrors.tds.net/pub/kde/stable/$pkgver/src/kdesdk-$pkgver.tar.bz2
+ not-glibc.patch"
+
+_builddir="$srcdir"/kdesdk-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ mkdir "$_builddir"/build
+}
+
+build() {
+ cd "$_builddir"/build
+ cmake -DCMAKE_INSTALL_PATH=/usr -DCMAKE_SKIP_RPATH=ON "$_builddir" || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="c4a223067a228688c6b62a6bdd67a022 kdesdk-4.6.3.tar.bz2
+00e1451447f9097a677c4606484077ca not-glibc.patch"
diff --git a/unmaintained/kdesdk/not-glibc.patch b/unmaintained/kdesdk/not-glibc.patch
new file mode 100644
index 000000000..646efb4f9
--- /dev/null
+++ b/unmaintained/kdesdk/not-glibc.patch
@@ -0,0 +1,12 @@
+--- kdesdk-4.6.3.orig/CMakeLists.txt
++++ kdesdk-4.6.3/CMakeLists.txt
+@@ -71,9 +71,7 @@
+ #include <stdlib.h>
+
+ int main() {
+-#ifndef __GLIBC__
+ choke me
+-#endif
+ return 0;
+ }" LIBC_IS_GLIBC)
+ if (LIBC_IS_GLIBC)