summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py-flask-enterprise/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-flask-enterprise/APKBUILD b/testing/py-flask-enterprise/APKBUILD
new file mode 100644
index 000000000..c5a0c8d78
--- /dev/null
+++ b/testing/py-flask-enterprise/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-enterprise
+_pkgname=Flask-Enterprise
+pkgver=1.0
+pkgrel=0
+pkgdesc="Flask enterprise capabilities"
+url="https://pypi.python.org/pypi/Flask-Enterprise"
+arch="noarch"
+license=" CDDL"
+depends="python py-flask"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="1d2636ddf33a77321a34ef2f29e5a995 Flask-Enterprise-1.0.tar.gz"
+sha256sums="58ba67ce015497ca7a361c681a4659aae3bfd440541461feca1e7c3719d1599f Flask-Enterprise-1.0.tar.gz"
+sha512sums="58800af378dc33e7ca312b21a9a26ee1f2979eeb7f33698d0459486506001dc7527dd70f38fc0e3f3121c9b2fb3c586f0cb72125141f556a8b9e15c6108eb8be Flask-Enterprise-1.0.tar.gz"