summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/ufsutils/APKBUILD6
-rw-r--r--main/ufsutils/uclibc-no-fstab.patch14
2 files changed, 10 insertions, 10 deletions
diff --git a/main/ufsutils/APKBUILD b/main/ufsutils/APKBUILD
index 2b0760c4a..68a3eb942 100644
--- a/main/ufsutils/APKBUILD
+++ b/main/ufsutils/APKBUILD
@@ -45,10 +45,10 @@ package() {
md5sums="e36f879da29e227e4d6494afc0c13559 ufsutils_8.2.orig.tar.gz
82077eb8980d3f9567910f61892c56f1 ufsutils_8.2-3.debian.tar.gz
-e63bb9f49b387e90d4a9bf9fef318b4a uclibc-no-fstab.patch"
+874a9b9fde380da5d27eda1a23880401 uclibc-no-fstab.patch"
sha256sums="6298d2a94fb601f6951bf81ce074e6af597e8867ac210d8ff73348aeb3738bd9 ufsutils_8.2.orig.tar.gz
6040ad18ddbf9fa37b87b084fe6cf19c50f63456d15b6726067c558f8383b795 ufsutils_8.2-3.debian.tar.gz
-8b581291d83dcdee402b2e441ca4e4026ba88d46a89a88182c65e6e7a85d99e7 uclibc-no-fstab.patch"
+c81681efed7ccc420b8e0eb78d5c9f4a4fd313459ab4393744fd7eb3e41188fa uclibc-no-fstab.patch"
sha512sums="f378372c2493c16fe8cb3977f4ed2d104e747895e97d7642d21b5e87a2a03ac696bbac093e534e13c2f1dc4638741edcbbb0ddec5abcbfa6b4f7401efbf7cf14 ufsutils_8.2.orig.tar.gz
7bc925e742eaf4e1837ca4b46afa7966490234492eeb40ad8fabf71550a79890f3294780c2dbdf3593a82fc8e0708cf4c72baba81f4fec9a884cfa545c8895c8 ufsutils_8.2-3.debian.tar.gz
-f3ba783768fcc0d595f715f3cf71ef64a13f7d3c7b9a6841b4681aceaa6c3c13a15a8d030e0e2141cd73c09cc52a15b315f4b05b63e61eaa0e08a74ff3331ca0 uclibc-no-fstab.patch"
+0d4337183fd4af63905306096c335ef75b83b61a92e3f20437649bca7b303aedc5c29080bf9816e04e5e17e1506a0196a36f25a998a2fe620adb1f75b5bb1499 uclibc-no-fstab.patch"
diff --git a/main/ufsutils/uclibc-no-fstab.patch b/main/ufsutils/uclibc-no-fstab.patch
index a96a25579..73f833874 100644
--- a/main/ufsutils/uclibc-no-fstab.patch
+++ b/main/ufsutils/uclibc-no-fstab.patch
@@ -5,7 +5,7 @@
#include <errno.h>
#include <fcntl.h>
-#include <fstab.h>
-+#ifndef __UCLIBC__
++#if 0
+# include <fstab.h>
+#endif
#include <paths.h>
@@ -15,7 +15,7 @@
ufs_disk_fillout_blank(struct uufsd *disk, const char *name)
{
struct stat st;
-+#ifndef __UCLIBC__
++#if 0
struct fstab *fs;
+#endif
struct statfs sfs;
@@ -25,7 +25,7 @@
} else if (ret >= 0 && (S_ISCHR(st.st_mode) || S_ISBLK(st.st_mode))) {
/* This is what we need, do nothing. */
;
-+#ifndef __UCLIBC__
++#if 0
} else if ((fs = getfsfile(name)) != NULL) {
/*
* The given mount point is listed in /etc/fstab.
@@ -64,7 +64,7 @@
#include <err.h>
#include <errno.h>
-#include <fstab.h>
-+#ifndef __UCLIBC__
++#if 0
+# include <fstab.h>
+#endif
#include <grp.h>
@@ -77,7 +77,7 @@
#include <string.h>
#include <ctype.h>
-#include <fstab.h>
-+#ifndef __UCLIBC__
++#if 0
+# include <fstab.h>
+#endif
#include <paths.h>
@@ -87,7 +87,7 @@
{
struct stat stblock;
char *newname, *cp;
-+#ifndef __UCLIBC__
++#if 0
struct fstab *fsinfo;
+#endif
int retried = 0, len;
@@ -97,7 +97,7 @@
if (len > 0 && origname[len] == '/')
/* remove trailing slash */
origname[len] = '\0';
-+#ifndef __UCLIBC__
++#if 0
if ((fsinfo = getfsfile(origname)) == NULL) {
printf(
"Can't resolve %s to character special device.\n",