summaryrefslogtreecommitdiffstats
path: root/main/bdftopcf
diff options
context:
space:
mode:
Diffstat (limited to 'main/bdftopcf')
-rw-r--r--main/bdftopcf/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/main/bdftopcf/APKBUILD b/main/bdftopcf/APKBUILD
new file mode 100644
index 000000000..49abcee74
--- /dev/null
+++ b/main/bdftopcf/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=bdftopcf
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="X.Org font utility"
+url="http://xorg.freedesktop.org/"
+license="custom"
+depends=
+makedepends="pkgconfig libxfont-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://xorg.freedesktop.org//releases/individual/app/bdftopcf-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-mapdir=/usr/share/fonts/util || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="148f20d28caaa69bbe7dcca7c2674fb6 bdftopcf-1.0.2.tar.bz2"