summaryrefslogtreecommitdiffstats
path: root/main/umix
diff options
context:
space:
mode:
Diffstat (limited to 'main/umix')
-rw-r--r--main/umix/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/main/umix/APKBUILD b/main/umix/APKBUILD
index ec07cc7e0..7200cd0ef 100644
--- a/main/umix/APKBUILD
+++ b/main/umix/APKBUILD
@@ -1,8 +1,8 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
-# Maintainer: Michael Mason <ms13sp@gmail.com>
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=umix
pkgver=1.0.2
-pkgrel=2
+pkgrel=3
pkgdesc="Program for adjusting soundcard volumes"
url="http://umix.sf.net"
arch="all"
@@ -13,9 +13,14 @@ install=
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
-build() {
- cd "$srcdir/$pkgname-$pkgver"
+_builddir="$srcdir"/umix-$pkgver
+prepare() {
+ cd "$_builddir"
+ update_config_sub
+}
+build() {
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,7 +33,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
}