summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/atop/APKBUILD2
-rw-r--r--main/chrony/APKBUILD4
-rw-r--r--main/cramfs/APKBUILD4
-rw-r--r--main/curl/APKBUILD6
-rw-r--r--main/dhcp/APKBUILD2
-rw-r--r--main/dialog/APKBUILD6
-rw-r--r--main/heimdal/APKBUILD2
-rw-r--r--main/libconfig/APKBUILD4
-rw-r--r--main/libxfce4menu/APKBUILD2
-rw-r--r--main/lua-uuid/APKBUILD2
-rw-r--r--main/man-pages/APKBUILD6
-rw-r--r--main/pax-utils/APKBUILD2
-rw-r--r--main/procps/01-fix-install-options-for-busybox.patch65
-rw-r--r--main/procps/APKBUILD13
-rw-r--r--main/snort/APKBUILD4
-rw-r--r--main/syslinux/APKBUILD2
-rw-r--r--main/uiconv/APKBUILD2
17 files changed, 100 insertions, 28 deletions
diff --git a/main/atop/APKBUILD b/main/atop/APKBUILD
index ecbfb102b..1b70c4075 100644
--- a/main/atop/APKBUILD
+++ b/main/atop/APKBUILD
@@ -8,7 +8,7 @@ license="GPL-2"
depends=
makedepends="zlib-dev ncurses-dev"
subpackages="$pkgname-doc"
-source="http://www.atoptool.nl/packages/atop-$pkgver.tar.gz
+source="http://www.atoptool.nl/download/atop-$pkgver.tar.gz
atop-bb-compat.patch
atop.initd"
diff --git a/main/chrony/APKBUILD b/main/chrony/APKBUILD
index 54d94e51d..a995bf10d 100644
--- a/main/chrony/APKBUILD
+++ b/main/chrony/APKBUILD
@@ -3,12 +3,12 @@ pkgname=chrony
pkgver=1.23
pkgrel=5
pkgdesc="NTP client and server programs"
-url="http://chrony.sunsite.dk/"
+url="http://chrony.tuxfamily.org/"
license="GPL-2"
depends="logrotate"
makedepends="texinfo"
subpackages="$pkgname-doc"
-source="http://www.sfr-fresh.com/linux/misc/chrony-$pkgver.tar.gz
+source="http://download.tuxfamily.org/chrony/$pkgname-$pkgver.tar.gz
$pkgname-1.20-conf.c-gentoo.diff
$pkgname-1.20-chrony.conf.example-gentoo.diff
$pkgname-1.21-makefile.diff
diff --git a/main/cramfs/APKBUILD b/main/cramfs/APKBUILD
index e40e57c2c..d552fec3c 100644
--- a/main/cramfs/APKBUILD
+++ b/main/cramfs/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: Natanael Copa <natanael.copa@gmail.com>
pkgname=cramfs
pkgver=1.1
-pkgrel=0
+pkgrel=1
pkgdesc="Linux filesystem designed to be simple, small, and to compress things well"
arch=""
url="http://sourceforge.net/projects/cramfs/"
license='GPL'
-depends="uclibc zlib"
+depends=""
makedepends="zlib-dev"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index a7bcbd03b..fb4ed38d6 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail.com>
pkgname=curl
-pkgver=7.19.7
+pkgver=7.20.0
pkgrel=0
pkgdesc="An URL retrival utility and library"
url="http://curl.haxx.se"
license="MIT"
depends=
makedepends="zlib-dev openssl-dev"
-source="http://curl.osmirror.nl/download/curl-$pkgver.tar.bz2"
+source="http://curl.haxx.se/download/curl-$pkgver.tar.bz2"
subpackages="$pkgname-doc $pkgname-dev"
@@ -25,4 +25,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="79a8fbb2eed5464b97bdf94bee109380 curl-7.19.7.tar.bz2"
+md5sums="3dda78c4a808d9a779dc3a2ae81b47d8 curl-7.20.0.tar.bz2"
diff --git a/main/dhcp/APKBUILD b/main/dhcp/APKBUILD
index 33f4e8531..ab15af69b 100644
--- a/main/dhcp/APKBUILD
+++ b/main/dhcp/APKBUILD
@@ -10,7 +10,7 @@ depends=
makedepends=
install="dhcp.pre-install dhcp.post-install dhcp.pre-upgrade dhcp.post-upgrade"
subpackages="$pkgname-doc $pkgname-dev dhclient dhcrelay"
-source="http://ftp.isc.org/isc/dhcp/$pkgname-$_realver.tar.gz
+source="http://ftp.isc.org/isc/dhcp/dhcp-4.1-history/$pkgname-$_realver.tar.gz
linux_ipv6_discover.patch
dhcp-3.0-fix-perms.patch
dhcrelay.initd
diff --git a/main/dialog/APKBUILD b/main/dialog/APKBUILD
index 99619e31c..a94e4f99d 100644
--- a/main/dialog/APKBUILD
+++ b/main/dialog/APKBUILD
@@ -1,13 +1,13 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dialog
-pkgver=1.1.20080819
+pkgver=1.1.20100119
_ver=${pkgver%.*}-${pkgver##*.}
pkgrel=0
pkgdesc="A script-interpreter which provides a set of curses"
url="http://invisible-island.net/dialog/dialog.html"
license="GPL"
-depends="uclibc ncurses"
+depends=""
makedepends="ncurses-dev"
install=
subpackages="$pkgname-doc"
@@ -24,4 +24,4 @@ build() {
make DESTDIR="$pkgdir" install
}
-md5sums="3caebd641a9f337b980becb4444336c5 dialog.tar.gz"
+md5sums="3d62219658fdddf3c6247fb45831a5d0 dialog.tar.gz"
diff --git a/main/heimdal/APKBUILD b/main/heimdal/APKBUILD
index e98d9cf01..49c35ea89 100644
--- a/main/heimdal/APKBUILD
+++ b/main/heimdal/APKBUILD
@@ -12,7 +12,7 @@ makedepends="gawk readline-dev e2fsprogs-dev>=1.41.9-r2 sqlite-dev autoconf auto
install=
subpackages="$pkgname-doc $pkgname-dev $pkgname-ftp $pkgname-telnet \
$pkgname-su $pkgname-rsh $pkgname-rcp $pkgname-pagsh $pkgname-kf"
-source="http://www.h5l.org/dist/src/$pkgname-$pkgver.tar.gz
+source="http://ftp4.de.freesbie.org/pub/misc/heimdal/src/$pkgname-$pkgver.tar.gz
001_all_heimdal-no_libedit.patch
002_all_heimdal-fPIC.patch
003_all_heimdal-rxapps.patch
diff --git a/main/libconfig/APKBUILD b/main/libconfig/APKBUILD
index cd2d6e001..e4bf50072 100644
--- a/main/libconfig/APKBUILD
+++ b/main/libconfig/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libconfig
-pkgver=1.4.1
+pkgver=1.4.3
pkgrel=0
pkgdesc="a simple library for manipulating structured configuration files"
url="http://www.hyperrealm.com/libconfig/"
@@ -24,4 +24,4 @@ package() {
make -j1 DESTDIR="$pkgdir/" install
}
-md5sums="7b2885272802b3ace56d3c8b445a4588 libconfig-1.4.1.tar.gz"
+md5sums="295f580a7bc3a03a44d520d6ace55ee6 libconfig-1.4.3.tar.gz"
diff --git a/main/libxfce4menu/APKBUILD b/main/libxfce4menu/APKBUILD
index 0023f2d93..4620483f7 100644
--- a/main/libxfce4menu/APKBUILD
+++ b/main/libxfce4menu/APKBUILD
@@ -9,7 +9,7 @@ depends=
subpackages="$pkgname-dev $pkgname-doc"
makedepends="libxfce4util-dev intltool pkgconfig gtk+-dev gettext-dev
libiconv-dev"
-source="http://mocha.xfce.org/archive/xfce-$pkgver/src/$pkgname-$pkgver.tar.bz2"
+source="http://i386.miwibox.org/distfiles/xfce4/$pkgname-$pkgver.tar.bz2"
build ()
{
diff --git a/main/lua-uuid/APKBUILD b/main/lua-uuid/APKBUILD
index 0f8f899be..0141699df 100644
--- a/main/lua-uuid/APKBUILD
+++ b/main/lua-uuid/APKBUILD
@@ -28,4 +28,4 @@ package() {
install -Dm755 uuid.so "$pkgdir"/usr/lib/lua/5.1/uuid.so
}
-md5sums="75f2e8c808c0fb375d9ec5255fd5d4de luuid.tar.gz"
+md5sums="e5bd7c2cf563ac4192b793934f545f49 luuid.tar.gz"
diff --git a/main/man-pages/APKBUILD b/main/man-pages/APKBUILD
index a827b0a79..78336bd56 100644
--- a/main/man-pages/APKBUILD
+++ b/main/man-pages/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=man-pages
-pkgver=3.23
+pkgver=3.24
_posixver=2003-a
-pkgrel=1
+pkgrel=0
pkgdesc="Linux man pages"
url="http://www.kernel.org/doc/man-pages/"
license="GPL"
@@ -27,5 +27,5 @@ build ()
rm "$pkgdir"/usr/share/man/man3/iconv*
}
-md5sums="4d0263bded9ad02a123ce11114ef76ac man-pages-3.23.tar.gz
+md5sums="083fc666f1f1143157901e96c9810539 man-pages-3.24.tar.gz
7c78aff03c0a6767ba483d34f19e4b09 man-pages-posix-2003-a.tar.bz2"
diff --git a/main/pax-utils/APKBUILD b/main/pax-utils/APKBUILD
index 8b31035f5..d950bd3e8 100644
--- a/main/pax-utils/APKBUILD
+++ b/main/pax-utils/APKBUILD
@@ -17,4 +17,4 @@ build() {
make DESTDIR="$pkgdir/" install
}
-md5sums="15a6f2ddadedac0ab6cd4b0683b767b9 pax-utils-0.2.tar.bz2"
+md5sums="a2097463fd5a34dd707b2d72d84aea89 pax-utils-0.2.tar.bz2"
diff --git a/main/procps/01-fix-install-options-for-busybox.patch b/main/procps/01-fix-install-options-for-busybox.patch
new file mode 100644
index 000000000..792a78155
--- /dev/null
+++ b/main/procps/01-fix-install-options-for-busybox.patch
@@ -0,0 +1,65 @@
+--- orig/procps-3.2.8/Makefile
++++ src/procps-3.2.8/Makefile
+@@ -27,7 +27,7 @@
+ ldconfig := ldconfig
+ ln_f := ln -f
+ ln_sf := ln -sf
+-install := install -D --owner 0 --group 0
++install := install -D -o 0 -g 0
+
+ # Lame x86-64 /lib64 and /usr/lib64 abomination:
+ lib64 := lib$(shell [ -d /lib64 ] && echo 64)
+@@ -222,10 +222,10 @@
+ ###### install
+
+ $(BINFILES) : all
+- $(install) --mode a=rx $(notdir $@) $@
++ $(install) -m a=rx $(notdir $@) $@
+
+ $(MANFILES) : all
+- $(install) --mode a=r $(notdir $@) $@
++ $(install) -m a=r $(notdir $@) $@
+
+ install: $(filter-out $(SKIP) $(addprefix $(DESTDIR),$(SKIP)),$(INSTALL))
+ cd $(usr/bin) && $(ln_f) skill snice
+--- orig/procps-3.2.8/proc/module.mk
++++ src/procps-3.2.8/proc/module.mk
+@@ -96,7 +96,7 @@
+ #################### install rules ###########################
+
+ $(lib)$(SOFILE) : proc/$(SONAME)
+- $(install) --mode a=rx $< $@
++ $(install) -m a=rx $< $@
+
+ ifneq ($(SOLINK),$(SOFILE))
+ .PHONY: $(lib)$(SOLINK)
+@@ -115,14 +115,14 @@
+ $(ldconfig)
+
+ $(usr/lib)$(ANAME) : proc/$(ANAME)
+- $(install) --mode a=r $< $@
++ $(install) -m a=r $< $@
+
+ # Junk anyway... supposed to go in /usr/include/$(NAME)
+ #INSTALL += $(addprefix $(include),$(HDRFILES))
+ #
+ #$(addprefix $(include),$(HDRFILES)): $(include)% : proc/%
+ #$(include)% : proc/%
+-# $(install) --mode a=r $< $@
++# $(install) -m a=r $< $@
+
+ ##################################################################
+
+--- orig/procps-3.2.8/ps/module.mk
++++ src/procps-3.2.8/ps/module.mk
+@@ -33,8 +33,8 @@
+
+
+ $(bin)ps: ps/ps
+- $(install) --mode a=rx $< $@
++ $(install) -m a=rx $< $@
+
+ $(man1)ps.1 : ps/ps.1
+- $(install) --mode a=r $< $@
++ $(install) -m a=r $< $@
+ -rm -f $(DESTDIR)/var/catman/cat1/ps.1.gz $(DESTDIR)/var/man/cat1/ps.1.gz
diff --git a/main/procps/APKBUILD b/main/procps/APKBUILD
index 83204ad1b..f0f169779 100644
--- a/main/procps/APKBUILD
+++ b/main/procps/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=procps
pkgver=3.2.8
-pkgrel=0
+pkgrel=1
pkgdesc="Utilities for monitoring your system and processes on your system"
url="http://procps.sourceforge.net/"
license="GPL LGPL"
@@ -9,7 +9,13 @@ depends=
# needs fancy install
makedepends="ncurses-dev coreutils"
subpackages="$pkgname-dev $pkgname-doc libproc"
-source="http://$pkgname.sourceforge.net/$pkgname-$pkgver.tar.gz"
+source="http://$pkgname.sourceforge.net/$pkgname-$pkgver.tar.gz
+ 01-fix-install-options-for-busybox.patch"
+
+prepare() {
+ cd "$srcdir"
+ patch -p1 -i "$srcdir"/01-fix-install-options-for-busybox.patch || return 1
+}
build() {
cd "$srcdir"/$pkgname-$pkgver
@@ -30,4 +36,5 @@ libproc() {
ln -s libproc-$pkgver.so "$subpkgdir"/lib/libproc.so
}
-md5sums="9532714b6846013ca9898984ba4cd7e0 procps-3.2.8.tar.gz"
+md5sums="9532714b6846013ca9898984ba4cd7e0 procps-3.2.8.tar.gz
+2b821e841acd08620789d5ffd19d58e9 01-fix-install-options-for-busybox.patch"
diff --git a/main/snort/APKBUILD b/main/snort/APKBUILD
index 15ac9717a..11010a3ad 100644
--- a/main/snort/APKBUILD
+++ b/main/snort/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=snort
-pkgver=2.8.5.1
+pkgver=2.8.5.3
pkgrel=0
pkgdesc="An open source network intrusion prevention and detection system"
url="http://www.snort.org/"
@@ -40,6 +40,6 @@ package() {
install -D -m 644 ../snort.confd "$pkgdir"/etc/conf.d/snort
}
-md5sums="b1abf3a9fa3486720c9a2b5eff920417 snort-2.8.5.1.tar.gz
+md5sums="ef02aaad54746603f2cb3236fe962128 snort-2.8.5.3.tar.gz
ffda56f7c20f5cea1c37c971e0f1d6c9 snort.initd
446f8d2b3435b8a6be738da978670605 snort.confd"
diff --git a/main/syslinux/APKBUILD b/main/syslinux/APKBUILD
index e543f31f6..0320b84a4 100644
--- a/main/syslinux/APKBUILD
+++ b/main/syslinux/APKBUILD
@@ -7,7 +7,7 @@ url="http://syslinux.org"
license="GPL"
makedepends="nasm perl"
depends="mtools"
-source="http://www.kernel.org/pub/linux/utils/boot/$pkgname/$pkgname-$pkgver.tar.bz2
+source="http://www.kernel.org/pub/linux/utils/boot/$pkgname/3.xx/$pkgname-$pkgver.tar.bz2
$pkgname-3.72-nopie.patch
"
subpackages="$pkgname-doc"
diff --git a/main/uiconv/APKBUILD b/main/uiconv/APKBUILD
index 3814bb565..a05aaa19d 100644
--- a/main/uiconv/APKBUILD
+++ b/main/uiconv/APKBUILD
@@ -14,4 +14,4 @@ build() {
make DESTDIR="$pkgdir" PREFIX=/usr/uiconv install
}
-md5sums="5cd7f80085324d08cb976fec674cd98d uiconv-0.3.tar.bz2"
+md5sums="de2ce8da53f32bdec578e1f0270fa15d uiconv-0.3.tar.bz2"