summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
Diffstat (limited to 'main')
-rw-r--r--main/gst-ffmpeg/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/main/gst-ffmpeg/APKBUILD b/main/gst-ffmpeg/APKBUILD
index d9441e8ca..f376e83c0 100644
--- a/main/gst-ffmpeg/APKBUILD
+++ b/main/gst-ffmpeg/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-ffmpeg
pkgver=0.10.10
-pkgrel=1
+pkgrel=2
pkgdesc="Gstreamer FFMpeg Plugin"
url="http://www.gstreamer.net"
license="GPL"
@@ -10,11 +10,12 @@ source="http://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-$pkgver.tar.b
build() {
cd "$srcdir"/gst-ffmpeg-$pkgver
- export CFLAGS="$CFLAGS -fno-strict-aliasing"
+ export CFLAGS="$CFLAGS -fno-strict-aliasing -fno-PIC"
+ export LDFLAGS="$LDFLAGS -nopie"
./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --with-ffmpeg-extra-configure="--enable-pic --disable-mmx --disable-mmx2" || return 1
+ || return 1
make || return 1
}